none
Synctoy V 2.1 very VERY slow

    Question

  • I just updated from V 1.4 to 2.1.  Now sync has run over 2 hours for a process that completed in 4 to 5 minutes.  Please advise me how to go back to V 1.4 on XP SP3 Pro machine.
    Tuesday, December 01, 2009 8:25 PM

All replies

  • Hi rfifry,

    Thank you for choosing SyncToy!

    I am sorry about the performance issue. SyncToy 2.0/2.1 use a different mechanism from the previous version, and they (SyncToy 2.0/2.1) take more time during the first sync to initualize necessary metadata. Then, the sequence sync sessions will run much faster. So would you mind try a second sync of the same folder pair, before you determine to go back to SyncToy 1.4, please?

    We have some other posts in the forum that talk about the performance issue coming with SyncToy 2.0/2.1. For Instance:
    http://social.microsoft.com/Forums/en-US/synctoy/thread/5c328ebb-2a7a-4fd1-b022-6a12e984d353/ .
    I hope the answers in such threads can give you some help.

    Thanks


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, December 02, 2009 9:44 AM
  • Hi JiGuang,
    the delays for completing only a single folder pair is unnecessarily long.  I cannot preform the required sync immeadiatly for all the folder pairs.  I have 12 folder pairs that cannot remain stagnant for the days it would take to sync using v2.1.  I located a copy of v1.4 and resumed quick syncronization.  The metafile creation process really takes to long.
    Wednesday, December 02, 2009 2:19 PM
  • Hi Rfifry,

    Just curious, how many files are there in the folder pair to be synced ? I saw a few msg about slowness of the first sync. as Jiguang said, SyncToy will need to add the metadata for each files being sycned to keep track of them for subsequent syncs. by providing # of files being synced will help us analysis this perf issue.

    thanks
    Yunwen
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, December 02, 2009 6:22 PM
    Moderator
  • I have noticed the same slow down since moving from 2.0 to 2.1.  The process starts quickly and gets moving, but if it is being run a parent directory that has over 100k files, it begins to slow down.  For instance: When I ran it on our user directory (which was getting executed every day before then) it took about 20+ minutes to do the preview.  It starts really fast, but then it starts to really take a lot of time to add actions for files.  By the end of the process it seems to take multiple seconds per action.  When I look at the processor usage, it is maxed out while this is occurring.  It seems like an internal database is being accessed and have a very inefficient search or insert statement.

    I don't know if this will be a good clue for you, but when I first run it and it is running fast, both cores are running at near 100%.  Like a switch, when it starts adding actions, it goes to 100% on only one core.  The slow down really happens fast once it starts adding actions.  I am watching it now... I think it takes the longest to add a file that has the same name in another directory already.  For instance, you have directories A, B, and C.  In A, B, C they all have a file called 1.doc.  The first action for 1.doc for directory A is fast.  The addition of 1.doc for directory B is slow, and the addition of 1.doc for directory C is painful.  I noticed that the copies themselves end up running very slow as well because they seem to take forever to log the change within synctoy.
    Friday, December 18, 2009 5:45 PM
  • Ok, I just wanted to add to this.

    I have used Synctoy for a while now and since I upgraded to Windows 7 x64 it has been depressingly slow. I did use 2.0 and tried upgrading to 2.1, installing all the other necessary files.

    I'm simplying doing what I have always done in Synctoy, Echo from my Documents to my USB hard drive. Nothing has changed other than the OS.
    When I run the sync my computer will become incredibly slow, both Cores on my Core 2 Duo E8400 run up to 100% usage and the file copy is unbelivably slow.

    This has become very infuriating and I have had to result to using a third party sync tool which works perfectly doing what I want Synctoy to do.

    Is this a 64bit issue? As I can run it on another machine running XP x86 with no problems what so ever.
    Wednesday, January 27, 2010 2:33 PM
  • I got the same issue at my Windows 7 X64 machine. No solution yet?
    Thursday, July 29, 2010 7:41 AM
  • I observe very similar behaviour here for a Vista 32bit machine. Synchronization on a network drive apparently converging... Maybe just the progress bar?
    Thursday, March 31, 2011 5:14 PM
  • It is a pity, but the same problem for my Windows Se7en 32bit machine. It appeared long after moving from 2.0 to 2.1, so that seems not the problem.

    I made a try-out last night: a score of 660 (!) synced files (small files).

    There must be a cause, .. and a solution. Otherwise, bye bye SyncToy (it is a pity).

    Tuesday, April 05, 2011 6:47 AM
  • Hi all,

    I was having the same problem with the sync being ridiculously slow, using 2.1 with Windows 7. After finding nothing online that helps, I realised my Recycle Bin was totally full, containing the overwritten and deleted files. I thought maybe having to move the files to my recycle bin while simultaneously deleting from it (because the bin is full) could be slowing it down.

    Lo and behold, I turn off the 'save overwritten files to recycle bin' and BOOM, 5000 music files in 10 minutes.

    This could explain why it starts so quick (filling up the bin) then slows down to all hell (bin is full).

    Anyway, hope that helps other people!

    Love from Australia.

    • Proposed as answer by Nyqu1st Monday, April 23, 2012 10:21 PM
    Monday, April 23, 2012 10:21 PM