none
401 Unauthorised - ReportViewer when in SSL Mode

    Question

  • Hi all,

    I am testing my .Net application and report server in SSL mode. 

    I have installed a cert and all looks fine (ReportManger is working fine in SSL mode). 

    My .Net application is suddenly getting a "The request failed With HTTP Status 401:unauthorised" when connecting to the SSL version of my RS web service. Non-SSL mode works fine.

    Do I need to change RS config on Reports Server?

    Thanks in advance!

    Keith. 

    Thursday, July 25, 2013 4:58 PM

All replies

  • Hi Keith,

    Thank you for your question. 

    I am trying to involve someone more familiar with this topic for a further look at this issue. Sometime delay might be expected from the job transferring. Your patience is greatly appreciated. 

    Thank you for your understanding and support.

    Regards,
    Charlie Liao

    If you have any feedback on our support, please click here.


    Charlie Liao
    TechNet Community Support

    Friday, July 26, 2013 4:46 AM
  • That would be great Charlie as I am hitting a brick wall with this

    It's 2008 R2.

    Friday, July 26, 2013 3:27 PM
  • Have you reset your Reporting Services web service reference as well to use https in place of http ? Also, Do you get prompted as you try to browse https URL from machine where application runs. Make sure RS' https URL is added to Local Intranet zone on App Server. Launch IE on App Server -> Gear Icon at Right top corner -> Internet Options -> Security -> Local Intranet -> Sites -> Advanced -> https://RSServerName ->Add
    Thursday, August 01, 2013 7:58 PM
  • Have you reset your Reporting Services web service reference as well to use https in place of http ?

    Yes.

    Also, Do you get prompted as you try to browse https URL from machine where application runs.

    Yes I get prompted for credentials

    Make sure RS' https URL is added to Local Intranet zone on App Server. Launch IE on App Server -> Gear Icon at Right top corner -> Internet Options -> Security -> Local Intranet -> Sites -> Advanced -> https://RSServerName ->Add

    I added the site but it has made no difference

    Answers above - still getting the 401 I'm afraid. 

    Tuesday, August 06, 2013 10:03 AM
  • 1. Do you get 401 only for Report Manager(RM) i.e. https://ServerName/Reports or for Report Server(RS) i.e. https://ServerName/ReportServeras well ? If its only for Report Manager, you need to setup DisableLoopbackCheck on Reporting Services box. Follow Method 2 mentioned in http://support.microsoft.com/kb/896861

    2. If you are getting 401 for both RM and RS, This could be because Kerberos Authentication is broken (maybe due in duplicate or incorrect SPNs). One way to confirm is to go to you rsReportServer.config (\Program Files\Microsoft SQL Server\MSRS11.MSSQLSERVER\Reporting Services\ReportServer)on Reporting Services box and have AuthenticationTypes to use RSWindowsNTLM only.

      <AuthenticationTypes>
       <RSWindowsNTLM/>
      </AuthenticationTypes>

    This is just to confirm is Kerberos is playing up. You may like to revert the changes and have RSWindowsNegotiate before RSWindowsNTLM and fix SPNs to make Kerberos work.

    Let me know if either of these steps help.

    Tuesday, August 06, 2013 5:17 PM
  • Keith_d99

    I hope your issue has been resolved. We'd mark the last comment as answer and closing this post. Please feel free to unmark it if you still see the issue.

    Thursday, August 15, 2013 5:56 PM