none
Word 2007 Documents.Open returns null in ASP.NET

    Question

  • Hi,

    In the following code the method Documents.Open returns null when running under ASP.NET, while running it in a console the code works fine. The computer is installed with Vista OS and Office 2007. The code works under ASP.NET on a windows 2000 server with Office 2003. (The website is configured with identity impersonate="true")

    Does anyone have any idea what is causing this?


            Object missing = Type.Missing;

            Application app = new Application();

            Object name = @"C:\a.doc";
            Object confirmConversions = false;

            Document doc = app.Documents.Open(
                ref name, ref confirmConversions,
                ref missing, ref missing, ref missing, ref missing,
                ref missing, ref missing, ref missing, ref missing,
                ref missing, ref missing, ref missing, ref missing,
                ref missing, ref missing
            );

            Object saveas = @"C:\b.doc";
            object fileFormat = 1;

            doc.SaveAs(ref saveas, ref fileFormat, ref missing,
                ref missing, ref missing, ref missing, ref missing,
                ref missing, ref missing, ref missing, ref missing,
                ref missing, ref missing, ref missing, ref missing,
                ref missing);
           
            app.Quit(ref missing, ref missing, ref missing);

    Friday, November 16, 2007 3:04 PM

Answers

  • Hi everyone.

    Try this:

    -  Create a  new "Desktop" directory inside of "C:\Windows\SysWOW64\config\systemprofile\"

    it works for me after a long long long day searching for the solution.

    It seams to be a profile problem.



    Wednesday, October 07, 2009 12:09 AM
  • thx god after 2 days i solve this problem Smile

     

    you must change the identity of word component in

     windows\System32\comexp.msc

    to be interactive user instead of launching user

    Monday, December 10, 2007 8:04 AM
  • Hi,

    I am able to solve the problem. If anybody interested, ping me.

    Mine is Vista O/S with Office 2007.

    I did a lot of settings. Not sure which one will helped it :)

    1. Set the DCOM Config Setting for "Microsoft Office Word 97 - 2003 Document"  
        (Open the properties > Identity Tab > Select "The interative User"
        Secutiry Tab > Lanuch and Acctivation Permissions > Add IUSR_<machinename> (for XP) Network Serivce (for VISTA)
    Save the settings


    2. Open your Virtual directory in IIS 

            FOR XP...
    1. Open Inetmgr
    2. open the Virtual directory properties
    3. select "Directory Secuirity" Tab.
    4. Click on "Edit" under anonymous access and authentication control
    5. Dialog box will get opened there you just click on browse
    6. then Click on "Advanced" and then "findnow".
    7. All the user list will get displayed fromt hem you select the admin account (any admin user is good)

             FOR VISTA...

    1. Open Inetmgr
    2. Select the Virtual directory
    3. select "Authentication".
    4. Edit anonymous authentication
    5. Dialog box will get opened > click on set >  admin user (any admin user is good)

     

    Hope this info helps all..

    Thanks
     - Venkat


    Thursday, February 12, 2009 6:14 AM

All replies

  •  

    Do you are sure that IIS anonymous user or current authenticated user have the nessesary permissions to open a file at its path?

     

    Save the file in a folder that your user can to access, or set the required permissions to open it, but I don't recomment to you to set permissions for the root path of your Hard Disk.

     

    Regards,

    Friday, November 16, 2007 11:45 PM
  • Yes, I've set the web.config to give the necessary persmissions (the user has administrator rights):

     

    <identity impersonate="true" userName="user" password="password"/>

     

    I've done some further testing and found that it doesn't matter if the file exists or not. Starting and stopping the Word application works by the way.

     

     

    Monday, December 03, 2007 10:05 AM
  • thx god after 2 days i solve this problem Smile

     

    you must change the identity of word component in

     windows\System32\comexp.msc

    to be interactive user instead of launching user

    Monday, December 10, 2007 8:04 AM
  • I have the same problem.

    Please ssssasa, could you explain how to change the identity of the word component ? I can't find the component in comexp.msc...

    Thank you very much...

    Thursday, April 17, 2008 6:29 PM
  • Hi,

    All the application Components in  comexp.msc are listed under:

    Component Services,
    Computers
    My Computers
    DCOM Config
    <LISTED APPLICATIONS COMPONENTS>

    But I am unable to find the Word Application Componets here.
    Can anyone tell me what is the Microfost World application Component called in this folder?

    Friday, August 22, 2008 10:07 AM
  • I can see under "Component Services->Computers->My Computer->DCOM Config->Microsoft Word Document".  right click properties selection "Identity" tab...

     

    • Proposed as answer by Mukesh Ajmera Wednesday, July 18, 2012 10:13 AM
    Friday, August 22, 2008 9:50 PM
  • Hello there,

    Under DOMConfig there is no component listed as "Microsoft Word Document". I have the Microsoft Office Word 2007 installed in my computer and runs on Vista. I want to know if the "Microsoft Word Document" is known with a different name in the DOMConfig? 
    Thursday, September 04, 2008 7:50 AM
  • I'm having the same problem, i also use windows vista and there's no Microsoft Word Document option under DOMConfig.. Actually, I couldn't find the Microsoft Word Document option anywhere in the comexp.msc.... I found an option named Microsoft Document Explorer, but it didn't work when i changed it... Anybody has a solution for this, please??

    Thanks
    Thursday, October 30, 2008 6:38 PM
  • You'll probably find a component called {00020906-0000-0000-C000-000000000046} which will be your winword application. Unfortunately I haven't been able to solve the null value by setting the identity of this component; it just won't work for some reason.

     

    The word process is started under the correct account (I checked via taskmanager) but it's not loading the document.

     

     

    I'm running win2008 with Office 2007 installed.

    Wednesday, December 17, 2008 3:19 PM
  • No, unfortunately I didn't. I'm now using a 3rd party component to generate Word documents, works a lot faster and without any errors. So all posts mentioning that Word interop shouldn't be used for server side generating of document are actually right Wink

    Monday, January 19, 2009 8:05 PM
  • Hi,

     

    What is this 3rd party component?

     

    thks

     

    Monday, January 19, 2009 9:04 PM
  • There are several, but I'm using Syncfusion DocIO. Works like a charm. Generating, searching text, mailmerging and lots more, all quick and simple to code.

    Monday, January 19, 2009 10:07 PM
  • I solve the problem by above requests but now problem is different ...When i run that application in client machine it execute(open the word) it server in lan....

     

     

    Please give me solution to solve...

     

    problem:

    ------------

    I publish a site in the machine 20.0.1.102 when i try to open in the same machine it get open and when i log in as admin in another system and change "DCOMCNFG" as i done here and while i try to run as http://20.0.1.102/mail/mailmerge.aspx this application open where i have publish..

     

    Please give me correct solution to solve urgent....

     

    mail me if u can......sujayathm@hotmail.com

    Thursday, January 22, 2009 11:27 AM
  • Using DCOMCNFG setting which given in other site i have solve but now the problem is I m having page in the Server Machine. While i m trying to open word file in Client Machine file is opening in Server only.

    Friday, January 23, 2009 4:09 AM
  • Hi,

    I am able to solve the problem. If anybody interested, ping me.

    Mine is Vista O/S with Office 2007.

    I did a lot of settings. Not sure which one will helped it :)

    1. Set the DCOM Config Setting for "Microsoft Office Word 97 - 2003 Document"  
        (Open the properties > Identity Tab > Select "The interative User"
        Secutiry Tab > Lanuch and Acctivation Permissions > Add IUSR_<machinename> (for XP) Network Serivce (for VISTA)
    Save the settings


    2. Open your Virtual directory in IIS 

            FOR XP...
    1. Open Inetmgr
    2. open the Virtual directory properties
    3. select "Directory Secuirity" Tab.
    4. Click on "Edit" under anonymous access and authentication control
    5. Dialog box will get opened there you just click on browse
    6. then Click on "Advanced" and then "findnow".
    7. All the user list will get displayed fromt hem you select the admin account (any admin user is good)

             FOR VISTA...

    1. Open Inetmgr
    2. Select the Virtual directory
    3. select "Authentication".
    4. Edit anonymous authentication
    5. Dialog box will get opened > click on set >  admin user (any admin user is good)

     

    Hope this info helps all..

    Thanks
     - Venkat


    Thursday, February 12, 2009 6:14 AM
  • To generate Word documents server side, you should really take a look at Xpertdoc Studio does. You can design the word document directly in Microsoft Word, and then compile this into an executable assembly that run server side without any security issues. You can develop these templates in C# or VB.NET and add any custom code directly inside Microsoft Word.

    www.xpertdoc.com
    Wednesday, March 11, 2009 6:36 PM
  • hi,

    On me the problem persists, at the begining it displayed me a security exception, until i added <identity impersonate="true" userName="user" password="password"/> (admin) on web.config.

    I've followed VenkatPV steps and it continues null, i'm using IIS 7, windows server 2008, office 2007 and interoop 12.0.

    Thursday, March 26, 2009 2:02 PM
  • This problem often does not occur on a 32bit OS, but it'll fail on a 64bit OS. It looks like even if you allow word to interact with the desktop by changing the DCOM config, it won't be able to access the disk.

    Can you work with your instance, but you can't open a file, or save it on disk because you don't have any rights in your context?
    Friday, March 27, 2009 2:23 AM
  • thx god after 2 days i solve this problem Smile

     

    you must change the identity of word component in

     windows\System32\comexp.msc

    to be interactive user instead of launching user


    Thanx very much ..guys THIS IS THE SOLUTION to the problem..make it launching user

    Wednesday, May 20, 2009 11:21 AM
  • Solution provided by VenkatPV actually works. You have to set the DCOM Config Setting for "Microsoft Office Word 97 - 2003 Document" even if you use Word 2007.

    • Edited by Shirotsugh Tuesday, August 25, 2009 8:57 AM typing error
    Tuesday, August 25, 2009 8:51 AM

  • The Dcom configuration for Word is working for Vista but it does'nt work for Windows server 2008.

    I use the same console application to test if it was working when the console app is launched by a user, there is no problem the document is loaded.
    But when it's loaded by Sql server Agent with the identity of the same user Documents.Open returns always null.

    How can I make my application work when it is launched by Sql agent ?

    Is there anyone who made it work with windows server 2008 ?

    Tuesday, September 29, 2009 3:27 PM
  • Hi everyone.

    Try this:

    -  Create a  new "Desktop" directory inside of "C:\Windows\SysWOW64\config\systemprofile\"

    it works for me after a long long long day searching for the solution.

    It seams to be a profile problem.



    Wednesday, October 07, 2009 12:09 AM
  • It's working, thank you very much Giovanny.

    You saved me.
    Thursday, October 08, 2009 4:45 PM
  • Thanks a lot Giovanny!!! It is working for me )))

    Friday, October 16, 2009 9:33 AM
  • Hi everyone.

    Try this:

    -  Create a  new "Desktop" directory inside of "C:\Windows\SysWOW64\config\systemprofile\"

    it works for me after a long long long day searching for the solution.

    It seams to be a profile problem.




    Thanks Giovanny, it´s work for me too... but, i dont know why!

    Like you, i was searching for soluation a loooong loooooong time.
    I´m using Windows Server 2008 and Office 2007.
    Thursday, November 05, 2009 11:34 AM
  • The reason is the temp files. The temp files are saved to that directory.
    Saturday, November 07, 2009 5:45 AM
  • Hooray for Giovanni! Thanks for posting this.

    And... thanks to Microsoft for the clear error message. :-( Temp files in the Desktop folder?!

    Groente, Michel
    Monday, November 23, 2009 3:05 PM
  • That almost worked for me. What I found was that, unless the account that I was impersonating was logged onto the box, than I still got the hung process, and null for the doc object.

    If howerver, I created a dummy service (or used any existing service) and ran it with the credentials I was using during impersonation, than that seemed to allow it work without being logged onto the box.

    Hack upon Hack unfortunately.

    Thanks again to Giovanni for the Desktop folder solution.
    Wednesday, December 09, 2009 3:31 PM
  • Thanks Giovanni for the Desktop folder solution it is working on windows 7 also.
    Monday, January 18, 2010 10:10 PM
  • Hi Giovanny,

    Thanks a lot. You saved me a week. Perfectly working with your desktop folder solution. Mine is windows 2008  and running console through Schedule task.

    Thanks again....
    Sunday, March 07, 2010 2:37 AM
  • Thanks Giovanny, I owe you a beer!

     

    Thursday, April 15, 2010 4:33 PM
  • Hi Giovanny, thanks a lot, you saved my time, save my life...
    Monday, May 31, 2010 6:38 AM
  • Hello,

    I am using office 2003 in windows server 2008 x64, and found that you need to launch the comexp.msc from here: C:\Windows\SysWOW64>comexp.msc

    It seems that the 32-bit versions are located in the SysWOW64 folder.


    Steffan
    Steffan
    • Proposed as answer by brianknet Friday, June 17, 2011 3:29 PM
    Wednesday, July 07, 2010 2:53 PM
  • Recently I came along a very unnerving and very similiar problem. What I wanted to do was

    • Opening Word
    • Opening a Word 2003 Document
    • Saving the document as Word 2007 Document (docx)
    • Closing the doc
    • Closing Word

    Since I want to run my code indepentend to whether Word2003 or Word2007 is installed, I wrote a simple Wrapper Library in which I load the adequate Word Assembly at runtime invoking all the methods via System.Reflection.

    When I executed the code below in a WinForms App (OS: Win7) everything worked fine. But running the code in a windows service the Word.Documents.Open Method would always return a null value.

    office = new Office(OfficeVersion.Office2007);
    office.Word.OpenWord(false);
    office.Word.OpenDocument(FileName, false);
    office.Word.SaveAs(FileName + “x”, office.Word.DocxFormat);
    office.Word.CloseDocument(false);
    office.Word.CloseWord(false);

    I couldn’t figure out why that would happen, since both the win service and the winword.exe processes where running under the right user account, which had all the rights and privileges needed. I was trying different things and searching the internet, desperate for a solution and not far from ripping my hair out, when I finally found this thread where you give the hint to look up the DCOM Config. So this is what I did to solve the problem:

    • Open C:\Windows\System32\comexp.msc
    • Under DCOM Config I found an entry Microsoft Word 97 – 2003 Document
    • And in the properties I set Identity to a specific user (with Admin Rights)

     

    I have UAC activated on my Win7 and I didn’t try if turning it off would solve the issue too. I also don’t really get why the DCOM Config “The launching user” would not work, since the user who runs the process is the same that I defined here… Any ideas will be appriciated.
    Thursday, September 02, 2010 9:48 AM
  • (Copied sol from http://social.msdn.microsoft.com/Forums/en/windowscompatibility/thread/742e4b7c-594d-4c10-8bae-f8d398d0e190 .. thanks to Rajeswari Sathyaseelan)

     

    Tried each one and both worked to solve the null return....


    1. Issue in opening word document (from DCOM component, in windows 2008 64 bit machines)

    create folder called "Desktop" under "C:\Windows\SysWOW64\config\systemprofile" or "C:\Windows\System32\config\systemprofile" as mentioned in http://social.msdn.microsoft.com/Forums/en/innovateonoffice/thread/b81a3c4e-62db-488b-af06-44421818ef9

    2. Steps to configure word to run as “Interactive User”
      1. open registry editor (regedit)
     2. Search for winword.exe, copy the AppId/Guid for word from “HKEY_CLASSES_ROOT\AppID\WINWORD.EXE”
     3. Open Compent Services (dcomcnfg), Go to Computers->MyComputer->DCOM Cnfg
     4. Select the application with the guid copied from registry.
     5. Right click on it, select properties, select Identity tab, select “Interactive User”, click on “Apply” button.

    • Proposed as answer by solversa Wednesday, November 24, 2010 2:07 AM
    Wednesday, November 24, 2010 2:07 AM
  • Thanks Giovanny - this solved the issue for us here in our office using 64-bit Windows 7, and Office 2007.
    Thursday, November 25, 2010 3:24 PM
  • MASTERRRRRRRRRRRRRRR sos un groso!!!!, capooo, muchas gracias por la solucion!!!!

    Thank you very much...you are the best.

     

     

     

    Tuesday, February 01, 2011 4:01 PM
  • There seems to be a bug in Server 2008 R2 and Windows 7.

    If you create an ole object from a service it does not inherit the environment from the service. Instead the environment is that of the internal admin user.

    Run procexp from sysinterals and look at Properties->Environment you will see that USERNAME is set to the Internal User.

    In other windows including Windows Server 2008 R1 this works correctly.

    By creating C:\Windows\SysWOW64\config\systemprofile\Desktop Word will start with the Internal user.

    On work around that might work is to start word with shellexecute and then catch the running session.

    Tuesday, February 08, 2011 3:28 PM
  • Thank you! This, finally, solved my problem! :)
    Thursday, February 17, 2011 4:30 PM
  • I have exactly the same problem when launchin a .NET app in Task Scheduler that automates Word. Giovanny's suggestion worked perfectly for me.

     

    Thanks!

     


    Simon Goldstone www.ActiveDataTools.com Data Cleansing, Correction and Management Software
    Thursday, April 21, 2011 2:18 AM
  • Yes! I have a C# ASP.NET app that is calling the Microsoft Offce 2007 (Word) interop .dll on Windows Server 2008 64-bit.  I use this to do a find and replace and then save the Word document.

    I was getting this error from my web service:

    Retrieving the COM class factory for component with CLSID {000209FF-0000-0000-C000-000000000046} failed due to the following error: 80070005.

    The issue is that I need to grant activation permissions in Component Services, BUT when I open Component Services on Windows 2008 64-bit, I don't see any Microsoft Word or Office entry.

    The solution is what Steffan suggests: open the C:\windows\syswow64\compexp.msc and now I see the "Microsoft Office Word 97-2003 Document" entry in DCOM Config!

    Don't pay vendors; think it out!!

    I now have a solution to allow my 32-bit webapp to run in production (which is still in Windows 2003 and IIS 6, and won't change any time soon.)  But I can develop in my own VM on Windows 2008 64-bit using the same code source in Visual Studio 2005.

    Kudos to Steffan.  (The same issue exsists with ODBC actually. I need to open c:\windows\syswow64\odbcad32.exe to see my 32-bit DSN's...)

    Friday, June 17, 2011 3:29 PM
  • Giovanny
    This worked like a charm! all I can say is thank you very much!! 
    Monday, August 01, 2011 10:52 AM
  • Thank you for the solution. Recently came accross the same issue and I was able to resolve it quickly after seeing your post.
    Wednesday, October 19, 2011 7:02 PM
  • Thank you it works. 2 days cant find the solution end finally thanks Giovanny....

    I´m using Win Server 2008 R2 and Office 2010

    Monday, October 24, 2011 2:27 PM
  • solversa,Thank you very much,you saved my time.
    Friday, November 11, 2011 8:47 AM
  • My Dear Frind

     

    Thank you so much..... i have wasted 2 days i this and done in 2 seconds.....

     

    Thanks You so much...


    Pravesh Sharda [BPM Consultant], MS Framework 1.1/2.0+ WSS/MOSS 2007/10, Asp.net, SQL Server 2000/05/08, Biztalk Server http://www.blogger.com/profile/09257219215947786213
    Thursday, November 17, 2011 6:42 AM
  • omg , on first look I said "wtf? yea right..." , but after 2 hours of trying other things ... THIS HELPED ME! THANKS Giovanny

    (using Windows 2008 R2 + Office 2010 )

     
    • Edited by Zakos Thursday, February 23, 2012 9:18 AM
    Thursday, February 23, 2012 9:15 AM
  • Hi Giovanny,

    Thanks a loooooooottttttttttt

    It works for me.

    Wednesday, March 07, 2012 5:13 AM
  • Had the same issue today. A mix of Giovanni's solution (Desktop folder in systemprofile folder, where I added modify permissions for my service user account), and ssssasa's concise "windows\System32\comexp.msc", giving custom permissions to the same account, was sufficient to have it working immediately. No reboot, not even a service restart was necessary.

    It is notable not to get distracted by the fact that in (D)COM+, the node is named "Word 2003-2007 document" but is actually valid for the permissions on the "Word.Application" object of Office 2010 - must be a rename forgotten by MS.

    A similar solution applies to Excel 2010 automation, there the (D)COM+ node is correctly named "Microsoft Excel Application", and the Desktop folder is not necessary.

    Friday, March 09, 2012 5:03 PM
  • Thank you Giovanny!!!

    We are using Windows Server 2008 R2 Standard with an installed version of Word 2007 and your solution rocked!  I can invoke and operate on Word docs and Excel files within PeopleSoft PeopleCode on the server.

    Once again, thank you.

    Thursday, March 29, 2012 11:24 PM
  • Thank you SO much!! This also works on Windows 7 with Office 2010

    My Documents.SaveAs and Documents.Add and Documents.Open all had errors and returned null

    Microsoft.Office.Interop.Word

    ApplicationClassmyWordApp = newMicrosoft.Office.Interop.Word.ApplicationClass();

    Sunday, April 01, 2012 3:21 PM
  • thanks for your post....

    Big problem and smart solution,,, i wasted my 5 days .  for this. i  tried OpenXML a nd all those stuff.. but..

    once Office autoamtion comes in play under IIS.. then lots of issues....

    anyway thx dear

    Regards

    Pravesh kumar sharda


    Pravesh Sharda [BPM Consultant], MS Framework 1.1/2.0+ WSS/MOSS 2007/10, SQL Server 2000/05/08, Biztalk Server http://www.blogger.com/profile/09257219215947786213

    Friday, April 27, 2012 3:19 PM
  • It's working, thank you very much Giovanny.

    Thank you very much...you are the best.

    You saved me.

    • Proposed as answer by SyamSurapaneni Wednesday, May 30, 2012 2:41 PM
    Wednesday, May 30, 2012 2:41 PM
  • Thanks Giovanny!

    This is realy simple and effective solution of this problem on Windows Server 2008 R2.

    Best regards.

    Monday, June 25, 2012 5:39 AM
  • Works perfectly. How do you know?!?!?!

    Cheers!

    Tuesday, August 07, 2012 4:42 AM
  • A mi se sucedio en Windows 2008 Server 64 Bits,

    Lo solucione creando el directorio Desktop, en la carpeta

    C:\Windows\SysWOW64\config\systemprofile\

    Y listo.

    Solución: Quedó asi;:

    C:\Windows\SysWOW64\config\systemprofile\Desktop

    Wednesday, August 22, 2012 8:41 PM
  • Erm surely the point is that this API is not supposed to be used in Web Applications, there is statement that explicitly says that somewhere. There are problems with threading, security, handling also sorts of nasty stuff because the API is designed for interactive use. There are some 3rd party components to do this, but if you are using 2007+ then you should be using the Open XML SDK; http://msdn.microsoft.com/en-us/library/office/bb448854(v=office.12).aspx


    http://pauliom.wordpress.com


    • Edited by pkr2000 Friday, August 24, 2012 11:12 AM
    Friday, August 24, 2012 11:11 AM
  • It's good solution.


    Thanks..
    Thursday, November 15, 2012 1:37 AM
  • thx god after 2 days i solve this problem Smile

    you must change the identity of word component in

     windows\System32\comexp.msc

    to be interactive user instead of launching user

    Read this a few times, and didn't have a clue what you were talking about. I'm using IIS 7 on Windows 2008, and this really was the trick. To clarify for anyone that this might not make sense to:

    double click C:\windows\System32\comexp.msc

    Find This:

    Word 97-2003 DCOM Config

    Right click the icon, select 'Properties', and then set this setting:

    Interactive User

    And it works.

    Also, I configured my virtual path to use a specific user every time so I wouldn't have to worry about individual user's permissions. Your case may be different, but that's how it worked for me.

    Friday, November 16, 2012 12:27 AM
  • Thanks a lot .........Thanks a lot ..........Thanks a ton.

    It works like charm.......once again Thanks a lot..

    following was my problem...

    Actually previously the same code works on local and didn't work on server(32-bit OS). for that i have set all the permissions in the DCOM config for the word and Excel dlls. then it works in server also.

    But now the same code i have moved to the new server(64-bit OS), it didn't work even though  i have set all the required permissions in the DCOM config, i tried in all the possible ways.It was running good when i ran the application locally in the server through solution but getting the error "object reference not set to instance" when i ran through IIS.

    so after creating the directory named "Desktop" at the location "C:\Windows\SysWOW64\config\systemprofile\" in the server(64bit) it works like a charm.........

    Thanks once again...

    Azam


    Wednesday, December 19, 2012 1:39 PM
  • Maaaaannnn.. after almost 1 week trying to figure out the solution I found this.. Can't thank you enough for such a simple solution!
    Thursday, April 25, 2013 2:08 PM
  • Hi 

    I have a same issue, I am using 64bit Windows Server 2012 and IIS8, I tried all possible solutions, adding permissions to DCOM , creating Desktop Directory. Setting IIS virtual directory permissions etc. but issue is still there.

    Please help

    kashif

    Friday, November 01, 2013 2:12 AM
  • Don't do it, use the intended library   http://msdn.microsoft.com/en-us/library/office/bb448854(v=office.12).aspx

    http://pauliom.wordpress.com

    Friday, November 01, 2013 6:18 AM
  • Thanx .this worked for me 
    Tuesday, December 24, 2013 9:51 AM