none
HTTP Error 401.2 - Unauthorized. You are not authorized to view this page due to invalid authentication headers. ????

    Question

  • HTTP Error 401.2 - Unauthorized. You are not authorized to view this page due to invalid authentication headers.

    This is On Premise, Version 4.0. I allowed CRM to use the default port 80 and the server is running on Windows Server 2008 R2 with SQL Server R2 and IIS 7 in compatibility mode. I do not see WindowsAuthenticationModule inside of IIS Manager? I tried to enable Analymouse Access and just get a blank page when attempting to view CRM by typing the server name into the Address bar.

    I read a few articles and found a few related issues but nothing concrete?

    http://social.microsoft.com/Forums/en/crmdeployment/thread/5b32358b-3aac-4f69-9fa5-0506d57f49c4

     

    Here are the Specs for the Server:

    Windows Server 2008 R2

    Microsoft SQL Server 2008 Enterprise Edition

    IIS 7.0

    Microsoft Dynamics CRM Enterprise Edition.

    I installed it on default port 80.

     

     

     

    Wednesday, February 16, 2011 10:26 PM

All replies

  • You may also like to have a look at IIS logs. Make sure your CRM website is configured correctly in IIS. You can try repairing the installation.


    Ashish
    Wednesday, February 16, 2011 10:34 PM
  • When repaoiring the installation I get the following error:

    Error accessing URL http://XXCRM01: The remote server returned an error: (401) Unauthorized.

    Also IIS logging appears to be enabled, however there doesn't appear to be any logs? (View Log Files is greyed out)

    Thursday, February 17, 2011 2:21 PM
  • Quick thought: Try repairing IIS installation
    Ashish
    Thursday, February 17, 2011 5:05 PM
  • It appears to be an issue with authentication, I uninstalled CRM and this time used port 5555 and got the same issue? I am not sure what to do now, how do I repair or even reset IIS?
    Thursday, February 17, 2011 10:22 PM
  • You should able to remove IIS component and add it back.

    Also check if your reporting server URL which you should have provided during CRM installation is working fine. Also look at ISAPI Filters and App ppol settings of your CRM site in IIS.


    Ashish
    Friday, February 18, 2011 12:07 AM
  • Hi,

    please see this KB article's http://support.microsoft.com/kb/907273  and  http://support.microsoft.com/kb/253667 i think it will be of some help.

     

     


    (prijil.p.s)

    Friday, February 18, 2011 10:17 AM