locked
How Do I Turn Off User Account Control: You Must Be Logged as an Administrator Issue

    Question

  • Howdy,

    Is it possible to completely turn off the User Account Control (UAC) feature in the current build? I created two users, the default Windows Live! ID user, which is by default a member of the local Administrators group. Also, I joined the PC to my domain and added myself as a domain user to the same local Administrators group.

    Whoami/all shows that my security descriptors are OK.

    However, attempting to the UAC off by dropping the slider in the User Account Control Settings window down to Never notify shows the following:

    You must be logged as an administrator of this computer to select this setting.

    Does anybody have a clue? Possibly, I am missing something?

     

    Thank you in advance!


    Well this is the world we live in And these are the hands we're given...
    Monday, September 19, 2011 7:48 PM

Answers

  • Hello,

    Thank you everybody for your help. With the next restart I was able to move the slider all the way down! I wonder why... but no messages about "your administrator" anymore. The PC is still in the same domain. The message had been showing for both local and domain user accounts.

    Possibly I had to restart the system after I moved the slider for the first time?

    Any clue?


    Well this is the world we live in And these are the hands we're given...
    • Marked as answer by Exotic Hadron Friday, September 23, 2011 12:25 PM
    Friday, September 23, 2011 12:25 PM

All replies

  • Have you tried running the UAC app from an elevated cmd window?

    That said, be aware that if you turn of UAC you will be unable to launch any of the Metro applications.

    Monday, September 19, 2011 7:51 PM
  • >> Is it possible to completely turn off the User Account Control (UAC) feature in the current build?

    Yes, it is possible but, as with previous releases, not recommended.

    1. Open secpol.msc
    2. Expand Local Policies
    3. Click Security Options
    4. Double Click "User Account Control: Run all administrators in Admin Approval Mode"
    5. Disable this policy
    6. Reboot

    Note that once UAC is disabled on the machine, Metro Style applications will not be able to run.

    If you want to run without seeing UAC prompts, and frequently need to run an elevated application (such as cmd.exe), without disabling the ability to run Windows Metro Style Applications, take these steps:

    1. Open Start and search for "User Account Control" in Settings
    2. Launch "User Account Control Settings"
    3. Set the slider to "Never notify"
    4. Click "OK"
    5. Create a new shortcut for cmd.exe on the desktop
    6. Open the shortcut's property dialog (on the desktop, rt-click and select properties --- on a touch device, press and hold the shortcut and touch "properties" when the dialog comes up)
    7. Click Advanced
    8. Check "Run as administrator"
    9. "OK"
    10. "OK"

     

    Thanks,

    Daniel

     

    Monday, September 19, 2011 8:32 PM
  • Have you tried running the UAC app from an elevated cmd window?

    That said, be aware that if you turn of UAC you will be unable to launch any of the Metro applications.

    John, do you mean running the control panel applet from cmd via runas /U:user@authority /trustlevel:0x40000?

    I thought when the UAC elevation prompt appears, the OS always starts the process elevated once credentials are verified, yes? Say, clicking Device Manager link in the Control Panel|All Control Patel Items|System window should prompt for credentials, and, when verified, you should be given elevated Device Manger window, shouldn't you?

    Seesh, I didn't know for Metro regarding UAC.

    Thank you.

     


    Well this is the world we live in And these are the hands we're given...
    Tuesday, September 20, 2011 9:57 AM
  • Daniel,

    Thank you for your reply!

    The problem is right in these steps:

    1. Open Start and search for "User Account Control" in Settings
    2. Launch "User Account Control Settings"
    3. Set the slider to "Never notify"

    I can't set the slider to "Never notify"! I get the "You must be logged as an administrator of this computer to select this setting." message at the bottom of the "User Account Control" window.


    Well this is the world we live in And these are the hands we're given...
    Tuesday, September 20, 2011 10:01 AM
  • >> I can't set the slider to "Never notify"! I get the "You must be logged as an administrator of this computer to select this setting." message at the bottom of the "User Account Control" window.

    Setting the slider position requires Administrator privileges.

    Try logging on as a member of the admin group.

     

    Tuesday, September 20, 2011 9:54 PM
  • >> I can't set the slider to "Never notify"! I get the "You must be logged as an administrator of this computer to select this setting." message at the bottom of the "User Account Control" window.

    Setting the slider position requires Administrator privileges.

    Try logging on as a member of the admin group.

     

    Daniel,

    As I stated in my previous post

     

     I created two users, the default Windows Live! ID user, which is by default a member of the local Administrators group. Also, I joined the PC to my domain and added myself as a domain user to the same local Administrators group.

     

    My accounts are already membering the local Administrators group. The security descriptors show that accounts have administrative privileges (whoami/all).

    That is why I am asking for help.


    Well this is the world we live in And these are the hands we're given...
    Wednesday, September 21, 2011 9:27 AM
  • I'm not able to reproduce that behavior logged on with a member of the Administrators group.

    Can you complete other admin tasks, such as creating a new user?

    Wednesday, September 21, 2011 8:53 PM
  • Maybe your Domain policy restricts it. Try to disconnect the PC from Domain and see if it works. So we know if it has something to do with the Domain rights or local rights.

    Microsoft MVP - Windows Expert (IT Pro)
    Wednesday, September 21, 2011 9:01 PM
  • Hello,

    Thank you everybody for your help. With the next restart I was able to move the slider all the way down! I wonder why... but no messages about "your administrator" anymore. The PC is still in the same domain. The message had been showing for both local and domain user accounts.

    Possibly I had to restart the system after I moved the slider for the first time?

    Any clue?


    Well this is the world we live in And these are the hands we're given...
    • Marked as answer by Exotic Hadron Friday, September 23, 2011 12:25 PM
    Friday, September 23, 2011 12:25 PM
  • I have a similar issue.  Every program I run in compatability mode always flags as suspicious behaviour.  At the moment the kids cannot use windows 8.  Not necessarily a bad thing I guess. 

    My next step was to go through each account individually and try and switch off the notifications, but presumably that was not the intention of the microsoft team.

    Tuesday, October 18, 2011 6:23 PM