locked
Change Custom Work Item Field to Reportable

    Question

  • I want to change the Reportable value of a custom work item field from None to Dimension. When I bring up the FIeld Definition dialog for this field the Reportable field is disabled. Can I change this value for existing custom fields, or will I have to readd the custom field with the correct reportable value?

    Thanks,
    Mike
    Friday, November 13, 2009 4:32 PM

Answers

  • AFAIK it is supported to change it from None to another value, but you cannot change once you have chosen one of the reportable values.

    Try editing the xml file directly by choosing the Open with option from the context menu.
    Ewald - Please remember to mark the replies as answers if they help.

    Ewald Hofman
    Blog: www.ewaldhofman.nl
    Friday, November 13, 2009 8:43 PM

All replies

  • AFAIK it is supported to change it from None to another value, but you cannot change once you have chosen one of the reportable values.

    Try editing the xml file directly by choosing the Open with option from the context menu.
    Ewald - Please remember to mark the replies as answers if they help.

    Ewald Hofman
    Blog: www.ewaldhofman.nl
    Friday, November 13, 2009 8:43 PM
  • Hi Mike,

    Did you try Ewald's suggestion? It works well for me. You can export and import the wit file with TFS Power Tools.

    Best Regards,
    Ruiz
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Sincerely, Ruiz Yi
    Monday, November 16, 2009 5:16 AM
  • Yes, I just did and the export/import process seemed to work just fine. My custom field now appears as a dimension. Unfortunately the only value being reported is 'Unknown'. I'll look for an answer to that in the WOrk Items forum.

    Thanks!
    Mike
    Monday, November 16, 2009 4:04 PM
  • Anyone found an answer to this issue yet? I mean that the only reported value being 'Unknown'.

    Thanks,
    Levi
    Wednesday, January 27, 2010 5:22 PM