locked
Update/Refresh Intellisense

    Question

  • Hi,

    It happens quite often when I write code in C++ that Intellisense doesn't show all of the existing class elements (variables, functions...). I have to hit Ctrl+Space several times or sometimes also have to delete the line and hit the buttons again for intellisense to show all of the possibilities.

    Does anyone know how this issue could be solved? It's really annoying. It never happened before when I was using .NET but now this problem appears really often.

    Regards,

    Niko
    Thursday, October 23, 2008 11:56 AM

All replies

  • Same happening to me with VS 2008 SP1 (not beta).

     

    Extremely annoying.

     

    is CTRL + space doesn't solve the problem for me.

    Thursday, January 15, 2009 11:38 PM
  • I have the same problem with SQL Server 2008.  This is just one example, but I've changed the name a few tables and intellisense just refuses to believe me.  I refreshed the Object Explorer at every level.  Do i really have to restart SSMS to sort it out.? 

    any ideas?
    Sunday, May 03, 2009 8:02 PM
  • For your information.  I found under Edit there is an Intellisense sub menu.  Here i found an option to Clear Local Cache.  This will reset the intellisense and bring it upto date.  It works fine in SQL, i can only imagine its the same in VS and C++ etc etc
    • Proposed as answer by mamastr Tuesday, May 05, 2009 3:22 PM
    Tuesday, May 05, 2009 3:22 PM
  • Nope.. Sorry to say, but there's no 'Clear Local Cache' under MSVC 2008.
    • Proposed as answer by Emir Akaydin Sunday, August 16, 2009 2:31 AM
    Wednesday, May 27, 2009 10:59 AM
  • As far as I know, intellisense information is kept in *.ncb file. Closing project, deleting this file and reopening project should help clearing the intellisense cache. But of course this is not the correct way to do it.
    Sunday, August 16, 2009 2:33 AM
  • Yes, Emir's suggestion worked for me. I couldn't solve it from options/menus/settings from Visual Studio, but deleting the .ncb file in the project directory forced VS to refresh it's IntelliSense cache. Thank you for the suggestion
    Monday, April 05, 2010 10:31 PM