locked
creating project "name" ... project creation failed. what to do?

    Question

  • I googled-around for I while but I can't find any fix that works for me whit MVC10++e, only MVC8++e and MVC9++e...
    How do I fix this problem?

    Windows 7 U 64bit
    Microsoft Visual C++ 2010 Express

    EDIT:

    Activate UAC again then install the express version again, start it and create a project.
    Close and disable UAC again =)


    No not me : (
    • Edited by specnopip Tuesday, January 25, 2011 8:53 PM Answer
    Monday, January 24, 2011 10:04 PM

Answers

  • Sorry for my incomplete text

    When I tried to start a new project in my vc++ I got a error down at the satusbar telling me this:

    Creating project 'name' ... project creation failed.

    And nothing happens after that, it dident mather if I tied to start a console project or win32 project.
    I tried vc++8 too, but the same error...

    After some reading on google I found that the problem is UAC. I needed to have UAC activated to install the program, or the installer don't get full access to registry (?), starting the installer as admin dident help. Neither did just setting the vc++ program to admin.

    So my problem I gone now, so I posted the answer in my first post if someone finds it on google =)


    No not me : (
    Wednesday, January 26, 2011 11:11 AM

All replies

  • vb10? This is a Visual C++ Express forum.
    Tuesday, January 25, 2011 12:19 AM
  • Hi specnopip,

     

    I’m not quite understand your question. Are you want to create a VC++ application using project name as “name” in VC++ 2010 express? If so, you can do this for sure. The following is the steps to create a console application project with name “name”.

     

    1.       Click File -> New -> Project in Visual C++ Express

    2.       Select Win32 Console Application

    3.       Fill the Name as “name”

    4.       Click OK

     

    These actions help you create a console application in default path. If you want to create a project at some special elevation required place such as C:\, you may need to run the Visual C++ Express as Administrator to bypass the UAC.

     

    If it doesn’t work for you, please post some error message here which helps to figure the problem out.

     

    Thanks

    Yi


    Yi Feng Li [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, January 26, 2011 10:04 AM
    Moderator
  • Sorry for my incomplete text

    When I tried to start a new project in my vc++ I got a error down at the satusbar telling me this:

    Creating project 'name' ... project creation failed.

    And nothing happens after that, it dident mather if I tied to start a console project or win32 project.
    I tried vc++8 too, but the same error...

    After some reading on google I found that the problem is UAC. I needed to have UAC activated to install the program, or the installer don't get full access to registry (?), starting the installer as admin dident help. Neither did just setting the vc++ program to admin.

    So my problem I gone now, so I posted the answer in my first post if someone finds it on google =)


    No not me : (
    Wednesday, January 26, 2011 11:11 AM
  • The UAC in Windows Vista/7 is a mixed bag.  I know that some people turn it off, but I think working in the paradigm is the best bet for the most part.  If it was turned off and you didn't do it and no one with access to your computer did it then you should quickly install a spyware/virus checker and make sure that there is nothing running on your machine that is doing this for nefarious purposes.

    Tom

    Wednesday, January 26, 2011 7:12 PM
  • vb10? This is a Visual C++ Express forum.

    <petpeeve>
    You edited your original post removing the reference to VB10. I can see that you were trying to clarify your original post, but this has the side-effect of making my follow-on post look completely disjointed. In future, I suggest that you clarify by simply appending a new post to the thread explaining the correction. Editing should really be reserved for grammar and spelling corrections.
    </petpeeve>

     

     

    Wednesday, January 26, 2011 7:19 PM
  • this problem gets solved by some registry editing methods in VC++2008, but for the 2010 version this problem still exists. I am stuck with this issue. Please someone help..
    Sunday, September 25, 2011 8:30 AM
  • this problem gets solved by some registry editing methods in VC++2008, but for the 2010 version this problem still exists. I am stuck with this issue. Please someone help..

    What problem is that? Are you trying to open a project in the C:\ directory?

    This has nothing to do with Visual Studio 2010. This is the default security settings on the directory for Vista and Windows 7.

    If I've misunderstood your problem, you should clarify. Better yet, start a new thread.

    Sunday, September 25, 2011 4:35 PM
  • i have this problem too.. i downloaded vc++ express 2008 and when i tried creating a new project i got the same error every time "project creation failed" so i downloaded vc++ 2010 and i still have the problem.. if any one can HELP.. please reply... i really need the answer.
    Sunday, October 02, 2011 10:19 AM
  • Assuming you are using Windows 7, right-click on the Visual Studio icon, and choose "Run As Administrator" menu item, and see if that solves your problem.
    Sunday, October 02, 2011 4:02 PM
  • I was having this exact problem with Visual Studio 2010 Ultimate (Windows 7 64 bit) which had installed correctly but when I tried to create a new project, I always got the message project creation failed. I couldnt find a solution any where on the internet which worked for me. After debugging, I got the following solution:

    1. First try the solution steps mentioned in http://masteranza.wordpress.com/2008/12/27/solution-vs-c-2008-project-creation-failed-bug
    2. If the above steps solve your problem well and good or move to step 3
    3. Run Regedit as an Administrator. Go to HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{f414c260-6ac0-11cf-b6d1-00aa00bbbb58}\InprocServer32
    4. Right click on InprocServer32 .You will notice that only the system account is present. Give Full Control access to the System account if not already present. Now, add your Administrator account (or the account with which you are trying to create the project) and give it Full Control access. Close the Regedit
    5. Now try to create a project again.

     

    Visual Studio tried to open the above registry key which belongs to McAfee (the antivirus on my system), when creating a project. Not sure why it does this, but as the key has a permission issue, it cannot open it.

    Sunday, November 20, 2011 7:07 AM
  • I found the same issue - used to have McAfee installed, but even though I uninstalled it months ago, the corrupted key remained in the registry - I discovered this by trying to run a normal javascript file and it failed, so if you have this problem and you also cannot execute .js files then maybe this is your issue as well?

    I resolved my problem by deleting all the McAfee related registry keys (remember, I no longer have McAfee on my system - DO NOT do this if you still have McAfee running on your system!) and then running regsvr32 jscript.dll (& for jscript9.dll) in both the System32 and SysWow64 folders. This was the only thing that worked for me. None of the registry permission fixes mentioned above worked for me.

    Good luck!

    Sunday, April 01, 2012 5:24 PM
  • Thank you ,I have problem already fine.very good master!

    Wednesday, July 18, 2012 11:52 PM