none
Workflow service

    Question

  • I've installed and configure the workflow manager with WF CU1 and Service bus CU 1 - but still I can't get it to Work...

    (probably because I'm missing the register part...:) ..)  

    I don't have any DNS entry for the Workflow site - I just have this in IIS:      

    I should use this to register... according to various articles:

    Register-SPWorkflowService -SPSite 'http://mySharepointDNSNAME/' -WorkflowHostUri 'http://WhatToTypeHere:12291'

    Also - does the WF manager needs do be installed on both 2 servers?

    one acts as WFE and the other acts as APP server?

    anyone?


    • Edited by JmATK Friday, December 27, 2013 8:55 AM
    Friday, December 27, 2013 8:41 AM

Answers

  • That would be your server name or FQDN. E.g.

    Register-SPWorkflowService -SPSite 'http://mySharepointDNSNAME/' -WorkflowHostUri 'http://SP2013:12291' -AllowOAuthOverHttp
    
    Register-SPWorkflowService -SPSite 'http://mySharepointDNSNAME/' -WorkflowHostUri 'http://SP2013.contoso.com:12291' -AllowOAuthOverHttp

    SP2013 is server name. Before running this command if you type 

    http://SP2013:12291

    in your browser it should return your some XML. If it does not return anything or times out then the above command wont work.


    Amit

    • Marked as answer by JmATK Friday, December 27, 2013 9:11 AM
    Friday, December 27, 2013 8:58 AM
  • You install WF manager on servers where you want to run Workflow. In your case I would say your app server should run workflow manager and WFE needs to have workflow client components.

    Amit

    • Marked as answer by JmATK Friday, December 27, 2013 9:20 AM
    Friday, December 27, 2013 9:17 AM

All replies

  • That would be your server name or FQDN. E.g.

    Register-SPWorkflowService -SPSite 'http://mySharepointDNSNAME/' -WorkflowHostUri 'http://SP2013:12291' -AllowOAuthOverHttp
    
    Register-SPWorkflowService -SPSite 'http://mySharepointDNSNAME/' -WorkflowHostUri 'http://SP2013.contoso.com:12291' -AllowOAuthOverHttp

    SP2013 is server name. Before running this command if you type 

    http://SP2013:12291

    in your browser it should return your some XML. If it does not return anything or times out then the above command wont work.


    Amit

    • Marked as answer by JmATK Friday, December 27, 2013 9:11 AM
    Friday, December 27, 2013 8:58 AM
  • You install WF manager on servers where you want to run Workflow. In your case I would say your app server should run workflow manager and WFE needs to have workflow client components.

    Amit

    • Marked as answer by JmATK Friday, December 27, 2013 9:20 AM
    Friday, December 27, 2013 9:17 AM
  • Hmm..done it all - also done a IISreset...but still no Sharepoint 2013 workflow options in Sharepoint designer...
    Friday, December 27, 2013 9:21 AM
  • Forgot to register it on the WFE, done that - now it Works .. :)

    thanks :)

    Friday, December 27, 2013 9:28 AM
  • Did your registration went smooth? Did you get any error message or did it register successfully? I am assuming you installed WF Manager on your App Server e.g. app01 and then went to your WFE e.g. wfe01 and installed WF client components. Opened management shell on wfe01 and ran the register-spworkflowservice there. If the above is true

    Check the following things

    1) Open your SharePoint Management Shell and type Get-WFFarmStatus. Most likely it wont be running.

    2) Now open your SharePoint Management Shell and type Get-WFFarm. This should give you your WF Farm configuration. What is endpoints value? 

    3) Also when you type your workflow host URI in browser does it return workflow xml configuration?


    Amit

    Friday, December 27, 2013 9:35 AM
  • Ahh. That explains it. I did not see your reply as I was in process of typing my reply. 

    Amit

    Friday, December 27, 2013 9:36 AM