none
C,C++ rebuild cause V.S 2010 to crash

    Question

  • Hello,

    I created a very simple console c++ application with V.S 2010 working under Win7-64

    Each time I rebuild the project it causes V.S 2010 to crash.

    Can you tell why ?

    How can I debug this problem ?

    With the same V.S 2010 I rebuilt a C# winforms application and it works great.

    Thanks,

    Z.V 

    Sunday, June 29, 2014 5:23 PM

Answers

  • Hello,

    Problem solved by running:

    regsvr32 "C:\Program Files (x86)\Internet Explorer\ieproxy.dll"

    It's important to run this version of ieproxy and not: C:\Program Files\Internet Explorer\ieproxy.dll

    because V.S 2010 is a 32 bits application.

    I got this solution using Microsoft premier support team.

    Thanks,

    Zvika

    • Marked as answer by Z. V Thursday, July 03, 2014 9:40 PM
    Thursday, July 03, 2014 9:39 PM

All replies

  • Hi Z.V,

    If you run your VS in safe mode, how about the result?

    http://msdn.microsoft.com/en-us/library/ms241278(v=vs.100).aspx

    Restart your machine, re-open your VS, please reset your VS settings, create a new project, test it again.

    http://msdn.microsoft.com/en-us/library/ms247075(v=vs.90).aspx

    Please also install the VS2010 SP1, if still no help, I suggest you repair your VS if all VC++ projects still have this issue.

    Best Regards,

     

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, July 01, 2014 11:22 AM
    Moderator
  • Hello,

    Attached the log file before the crash.

    Thanks,

    Zvika

    Tuesday, July 01, 2014 6:13 PM
  • Hi Zvika,

    It seems that you install some extension tools in your VS IDE, am I right?

    If so, as my previous reply, how about running your app in safe mode? If possible, I suggest you disable all add-ins in your VS IDE, and then test it again.

    To make sure that whether it is your project issue, please run it in other VS machine, if it works well, so we could make sure that it is not your project issue, so we need to check the VS IDE Environment or the Windows Environment. As my previous reply, maybe the extension tools impact your VS.

    If you don't have other Environment, maybe you could share us a sample, I will test it in my side, you know that it is hard to get the answer directly for the VS crashed issue, we need to narrow down it. Thanks for your understanding. 

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, July 02, 2014 3:01 AM
    Moderator
  • Hello,

    1. I tried launching V.S 2010 in SafeMode but got the same results.

    2. I did not install any "extension tools".

    3. I reboot the PC and reset all settings. Then I created a new project and got the same crash.

    4. The project I'm creating is a console application. I'm not change the settings of this project, just trying to rebuild it.

    Thanks,

    Zvika

    Wednesday, July 02, 2014 4:42 AM
  • Hi Zvika,

    If it has this issue when you rebuild it, how about use the option"clean/build"?

    If it has this issue in safe mode and a simple app still has this issue, I doubt that it is your VS IDE issue.

    As my previous reply, could you repair your VS? Test it again. Maybe it is the VS setup issue since it works well in my side.

    If you install any third party tools in your windows Environment, please close them. Please make sure that your task manager is free when you rebuild your app.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, July 02, 2014 6:57 AM
    Moderator
  • Hello,

    Upon clicking 'clean' V.S 2010 crashes.

    I reinstalled V.S 2010 and still has this problem.

    What do you mean by "third party tools in your windows Environment" ?

    Thanks,

    Zvika

    Wednesday, July 02, 2014 8:56 AM
  • Hello,

    Problem solved by running:

    regsvr32 "C:\Program Files (x86)\Internet Explorer\ieproxy.dll"

    It's important to run this version of ieproxy and not: C:\Program Files\Internet Explorer\ieproxy.dll

    because V.S 2010 is a 32 bits application.

    I got this solution using Microsoft premier support team.

    Thanks,

    Zvika

    • Marked as answer by Z. V Thursday, July 03, 2014 9:40 PM
    Thursday, July 03, 2014 9:39 PM