none
MSBuild Server-hosted can not find imported project

    Question

  • Hi. I have installed the MSBuild.ExtensionPack (From CodePlex) on our BuildServer, but when a build triggered inside of VS2012 I get the message: "error MSB4019: The imported project "C:\Program Files\MSBuild\ExtensionPack\4.0\MSBuild.ExtensionPack.tasks" was not found"

    I can run the very same .proj inside in a command-prompt at the server with no problem, it's only when I try to trigger it as a build definition it fails.

    (The .proj-file is located at the server, at D-drive if that's should matter.)


    Erik

    Friday, January 10, 2014 12:42 PM

Answers

  • Hi Erik, 

    Thanks for your reply.

    For this MSBuild Extension Pack issue, please create a new issue about it in this MSBuild Extension Pack ISSUES site for the better response. 


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Erik Jorman Tuesday, January 14, 2014 9:48 AM
    Monday, January 13, 2014 8:48 AM
    Moderator

All replies

  • Hi Erik, 

    Thanks for your post.

    What’s the version of your TFS? 

    As we know that TFS invoke MSBuild command to build project on build agent machine by default. So you need to ensure that: on build agent machine, try manually build your project using VS and MSBuild command separately, your project need can be built successfully on build agent machine. Please confirm this scenario on your build agent and share result here.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, January 13, 2014 2:53 AM
    Moderator
  • Hi.

    We are using TFS 2010.

    Build the project through MSBuild Command on the Agent-server works ok. (I have not executed it through VS IDE, this is a common standalone .proj, with some tasks for checking in through CI.)

    Regards



    Erik

    Monday, January 13, 2014 7:50 AM
  • Hi Erik, 

    Thanks for your reply.

    For this MSBuild Extension Pack issue, please create a new issue about it in this MSBuild Extension Pack ISSUES site for the better response. 


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Erik Jorman Tuesday, January 14, 2014 9:48 AM
    Monday, January 13, 2014 8:48 AM
    Moderator