none
Sharepoint database migration

    Question

  • For my SharePoint installation, the Sql server database that i required was installed on another PC under the same domain as my server(windows server 2008 R2). Now i created a VM(OS is windows server 2008) on hyper-V on my server and installed SQL server 2008 in it and moved the all the  SharePoint databases to the VM. I followed the link "http://technet.microsoft.com/en-us/library/cc512725(v=office.14).aspx#Prepare"to move my databases. Now even after adding the administrator users onto my new database and granting permissions i cant connect to the Central Administration page of my SharePoint site. When i use the SharePoint command shell to start CA i get "cannot access local farm". 

    Tuesday, April 08, 2014 12:01 PM

All replies

  • Hello,

    Have you reconfigured the SQL Server alias on the SharePoint server to point to the new database server?

    Did you enable TCP/IP protocol for the new instance? Have you configured Windows Firewall for SQL Server access on the new database server?  

    Hope this helps.

    Regards,

    Alberto Morillo
    SQLCoffee.com


    Tuesday, April 08, 2014 1:54 PM
    Moderator
  • Hi,

     I checked everything as you have asked , TCP/IP for the new instance was already enabled, firewall for my VM is disabled and now when i configure SharePoint Products i get configuration failed.

    Friday, April 11, 2014 6:38 AM
  • Did you check the service a/c is part of service group at AD level and you have given access for that.

    Also check the Identity pool has proper access type setup.


    Santosh Singh

    Friday, June 06, 2014 5:40 PM