none
how to avoid mozilla asked credentials in SSRS Reports?

    Question



  • Hi,

    I deployed an SSRS report on my PC and am able to access my report through report manager.

    When I copied that report URL and opened it on another PC over the network, it asked for credentials for Mozilla FF.

    i tried like in FF,

    The      about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise!, to continue to the about:config page.

    1. In the about:config page, search for the preference network.automatic-ntlm-auth.trusted-uris, and double-click on it.

    I added my server URL here,by that time its directly opened.

    I think its not correct way, If i pass URL to 100 systems did i do like above?

    Can anyone help me How to resolve it?

    How to avoid credentials (username and password) to open directly ?

    Tuesday, July 16, 2013 7:38 AM

Answers

  • Hi Samba777,

    The issue may occur if the Firefox does not pass the current user's credential to the Reporting Services automatically. By default, SQL Server Reporting Services uses the Windows Negotiate authentication which attempts Kerberos authentication first, but falls back to Windows NTLM authentication if Kerberos is not enabled. However, Firefox doesn't enable the Windows NTLM authentication by default. To avoid this issue, we have to configure the Firefox to allow the NTLM authentication manually on each machine. 

    Reference:
    Firefox asks for user name and password on internal sites

    Regards,


    Mike Yin
    TechNet Community Support

    Saturday, July 20, 2013 4:47 PM
    Moderator

All replies

  • Hi,

    please Can anyone help me by above scenario How will overcome ?

    or will we do when  configure the ASP.Net application from SSRS Report .

    Wednesday, July 17, 2013 10:05 AM
  • Hi Samba777,

    The issue may occur if the Firefox does not pass the current user's credential to the Reporting Services automatically. By default, SQL Server Reporting Services uses the Windows Negotiate authentication which attempts Kerberos authentication first, but falls back to Windows NTLM authentication if Kerberos is not enabled. However, Firefox doesn't enable the Windows NTLM authentication by default. To avoid this issue, we have to configure the Firefox to allow the NTLM authentication manually on each machine. 

    Reference:
    Firefox asks for user name and password on internal sites

    Regards,


    Mike Yin
    TechNet Community Support

    Saturday, July 20, 2013 4:47 PM
    Moderator
  • Hi Mike,

    I agree with you.

    Monday, July 22, 2013 5:34 AM