none
TF250049: The following URL for Team Foundation Server could not be verified

    Question

  • We are having an issue with integration of TFS 2010 with our existing SharePoint Farm – Test Farm.

    The issue is when I tried to grant access to TFS from SharePoint it’s showing the following error


    ---------------------------

    Team Foundation Error

    ---------------------------

    TF250049: The following URL for Team Foundation Server could not be verified: http://[tfsserver]:8080/tfs. The following error was received: TF250067: No connection could be made to Team Foundation Server at the following address: http://[tfsserver]:8080/tfs. Either the specified URL does not point to a server that is running Team Foundation Server, the server is not available, or the service account for SharePoint Products does not have sufficient permissions on that server. The service account for SharePoint Products might not have been added to the required group in Team Foundation Server. For more information, see the Microsoft Web site (http://go.microsoft.com/fwlink/?LinkId=161206).. This error must be corrected before you can grant access between Team Foundation Server and the SharePoint Web application. For more information, see the Microsoft Web site (http://go.microsoft.com/fwlink/?LinkId=161206).

    ---------------------------

    OK  

    Please note I installed TFS Extensions in all SharePoint WFE(s) and  added the SharePoint service account to the TFS as Administrator Console Users as you can see highlighted. 


     

    Once I could not make it work with this SharePoint Farm (Test Farm)I tried to connect to another SharePoint farm- Dev farm and following same steps it works well. The difference I found between these two farms is -- Test Farm is a multi server Farm and also in all web app we have Kerberos activated. On the other hand the dev farm is single server farm and no Kerberos installed.   TFS is using NTML as authentication.

     

    Any idea what is going on?


    Sardar M Guljar
    • Moved by Edwer Fang Friday, August 06, 2010 3:19 AM (From:Getting Started With Visual Studio Team System)
    Friday, August 06, 2010 1:11 AM

Answers

  • Hi Sardar:

    Workaround/Fix:
    While integrating a MOSS instance/ farm that is set to use Kerberos authentication, a Service Principal Name have to be set for the TfsService account on the “SharePoint web application” that will host the project portal sites and on the “Central administration” site of the MOSS instance /farm.
    To set the Service Principal Name (usually done by the Domain administrator), you could use the SetSPN.exe tool. The syntax would be
    Setspn.exe –S <web application url> <domain/TfsService>
    Setspn.exe –S <Central admin url> <domain/TfsService>
    To validate if a SPN is set for the TfsService account on these two url’s, you could run a Setspn.exe -L command
    Setspn.exe –L<domain/TfsService>
    This command will list the urls and services that are registered for the TfsService account.

    This  answer can be found in the following blog post as well:
    ========================================
    TFS 2010: Project collection creation fails with error: TF252005
    http://blogs.msdn.com/b/tfssetup/archive/2010/08/11/tfs-2010-project-collection-creation-fails-with-error-tf252005.aspx?wa=wsignin1.0

    Wendell

    Tuesday, August 24, 2010 12:10 AM
    Moderator

All replies

  • Does TFS join domain?

    Why not enable Kerberos for TFS?

    Wednesday, August 11, 2010 1:03 PM
  • As jocc is stating, the path to go would be to enable Kerberos for TFS and I would recommend including SSRS to use Kerberos if it is in the mix of functionality you require.

    regards,


    Enrique Lima Solutions Architect | Apparatus, Inc. | http://geekswithblogs.com/enriquelima
    Thursday, August 12, 2010 4:14 AM
  • Hi Sardar:

    Workaround/Fix:
    While integrating a MOSS instance/ farm that is set to use Kerberos authentication, a Service Principal Name have to be set for the TfsService account on the “SharePoint web application” that will host the project portal sites and on the “Central administration” site of the MOSS instance /farm.
    To set the Service Principal Name (usually done by the Domain administrator), you could use the SetSPN.exe tool. The syntax would be
    Setspn.exe –S <web application url> <domain/TfsService>
    Setspn.exe –S <Central admin url> <domain/TfsService>
    To validate if a SPN is set for the TfsService account on these two url’s, you could run a Setspn.exe -L command
    Setspn.exe –L<domain/TfsService>
    This command will list the urls and services that are registered for the TfsService account.

    This  answer can be found in the following blog post as well:
    ========================================
    TFS 2010: Project collection creation fails with error: TF252005
    http://blogs.msdn.com/b/tfssetup/archive/2010/08/11/tfs-2010-project-collection-creation-fails-with-error-tf252005.aspx?wa=wsignin1.0

    Wendell

    Tuesday, August 24, 2010 12:10 AM
    Moderator