none
SSAS Fehler: "Der Attributschlüssel wurde bei der Verarbeitung nicht gefunden" obwohl PK und FK in Datenbank vorhanden

    Frage

  • Hallo zusammen,

    Bei der Bereitstellung und Verarbeitung meines gesamten Analysis Service Projekts tritt folgenden Fehler auf:

    Fehler im OLAP-Speichermodul: Der Attributschlüssel wurde bei der Verarbeitung nicht gefunden: Tabelle: dbo_DimAuflage, Spalte: AuflageID, Wert: 187117. Das Attribut ist 'Auflage'. Fehler im OLAP-Speichermodul: Der Attributschlüssel wurde in ein unbekanntes Element konvertiert, da der Attributschlüssel nicht gefunden wurde...

    Wenn ich die betroffene Dimension alleine Verarbeite, tritt der Fehler nicht auf. Die Daten sind auch alle Vollständig. Zuvor kam der selbe Fehler nur in der Faktentabelle welche auf die Dimension referenziert. Durch anpassen der Fehlereinstellungen konnte ich dieses Problem allerdings "lösen" ( leider werden nun viele Daten ignoriert, also doch keine Lösung).

    Die IgnorError Methode kann ich nicht anwenden, da alle Daten von höchster Wichtigkeit sind und geladen werden müssen.

    An der Sortierung kann es auch nicht liegen, da das Feld AuflageID ein Int ist.

    Die komplette Datenbank neu laden habe ich auch schon probiert, leider ohne Erfolg (wie hier beschrieben)

    Eine Möglichkeit wäre noch der Arbeitsspeicher, wie unter diesem Link beschrieben. Allerdings handelt es sich um einen Kunden Server, daher würde ich Hardwareprobleme gern als letztes verdächtigen.

    Weiß jemand wie ich dieses Problem in den Griff bekommen kann? 

    Vielen Dank



    • Bearbeitet S. Elben Dienstag, 29. Januar 2013 16:34
    Dienstag, 29. Januar 2013 16:32

Alle Antworten

  • Wenn ich die betroffene Dimension alleine Verarbeite, tritt der Fehler nicht auf.

    Hallo,

    das ist doch schon die Lösung: Erst die Dimensionen vollständig verarbeiten, und erst im Anschluß den Cube. Oder habe ich was in Deinem Post überlesen?


    Olaf Helper

    Blog Xing

    Dienstag, 29. Januar 2013 18:19
  • Hallo Olaf,

    leider tritt der Fehler auf, sobald ich dann den Cube verarbeite (obwohl ich zuvor die Dimension alleine verarbeitet habe)

    Mittwoch, 30. Januar 2013 08:50
  • Basiert der Cube auf einem Snapshot / DWH, das in der Verarbeitungs-Zeit nicht geändert wird? Andernfalls kann es vorkommen, das zwischen Verarbeitung der Dimensionen und dem Cube Fakten mit neuen Dimensionsdaten eingefügt werden, was dann zu dem Fehler führt.

    Hast Du die Dimensionsdaten kontrolliert, ob die ID wirklich vorhanden ist? Du kannst auch Abfragen direkt gegen die Dimension ausführen; sieht vom Prinzip her so aus:

    SELECT {} ON 0
          ,{[dbo_DimAuflage].[AuflageID].&[187117]} ON 1
    FROM $dbo_DimAuflage;


    Olaf Helper

    Blog Xing

    Mittwoch, 30. Januar 2013 13:24
  • Der Cube basiert auf einem relationalen DWH welches sich auf der selben Instanz des SQL Servers befindet. Es werden keine Daten in das DWH geladen noch verändert während der Cube verarbeitet wird.

    Im Management Studio per SQL und auch im BIDS (per "Daten Durchsuchen") sind die Schlüssel vorhanden.

    Der ETL, welcher die Daten in das DWH läd, kann nur referenzierte Daten abspeichern. Daten ohne Schlüssel werden nicht beachtet. Es ist also unmöglich, dass der Schlüssel fehlt.



    • Bearbeitet S. Elben Mittwoch, 30. Januar 2013 16:31
    Mittwoch, 30. Januar 2013 16:26