locked
HILFE: Meine "Hilfe" spinnt !!!

    Frage

  • Wenn ich im Start-Menü von Windows 7 die "Hilfe und Support" aufrufe, bekomme ich folgende, mit einem gelben Ausrufezeichen versehene Fehlermeldung:

    "Es ist keine Verbindung mit der Onlinehilfe vorhanden, in der der aktuelle Inhalt angezeigt wird. Überprüfen Sie die Internetverbindung, und versuchen Sie dann erneut, eine Verbindung mit der Onlinehilfe herzustellen. Wenn diese Meldung weiterhin angezeigt wird, ist der Dienst der Onlinehilfe möglicherweise vorübergehend nicht verfügbar."

    Es kann m.E. aber nicht sein, dass der Dienst der Onlinehilfe auf Dauer nicht verfügbar ist.

    Im übrigen erscheint am Anfang des jeweiligen Hilfetextes unter dem Titel folgende kuriose Buchstaben-/Zeichen-Kombination:

    __elbasuer__

    Das Programm "WinHlp32.exe" für Windows 7 (KB917607) habe ich bereits installiert. Es hat aber keine Lösung gebracht. Auch die erneute Deinstallation hat nichts verbessert.

    Wenn ich aus einer Anwendung heraus - z.B. dem Internet Explorer 8 - auf das "Hilfe"-Icon klicke, bekomme ich folgende Fehlermeldung:

    Informationssymbol Thema nicht gefunden.

    Das von Ihnen gesuchte Thema ist in dieser Version von Windows nicht verfügbar. Zusätzliche Unterstützung finden Sie unter Weitere Supportoptionen.

    Klicke ich dann auf "Weitere Supportoptionen" kommt urplötzlich irgendein Thema, das ich aber in keiner Weise angefordert habe. So z.B.:

    Kann ich mehrere Betriebssysteme auf meinem Computer haben (Multiboot)?

    __elbasuer__

    Wenn auf der Festplatte des Computers ausreichend freier Speicherplatz vorhanden ist, können Sie mehrere Betriebssysteme installieren und anschließend auswählen, welches Betriebssystem beim Starten des Computers verwendet werden soll. Dies wird als Multiboot- oder Dual-Boot-Konfiguration bezeichnet und erfordert Partitionen auf Ihrer Festplatte. Weitere Informationen finden Sie unter Kann ich meine Festplatte neu partitionieren?

    Fazit: Meine Hilfe spinnt !!!
    Weiß jemand Rat?

    Mit freundlichen Grüßen
    Jürgen Krebs

    Mittwoch, 2. Dezember 2009 14:36

Antworten

  • Wenn ich es richtig mit bekommen habe, gibt es einen Bug in der Hilfe, die besagte Fehlermeldung bringt, wenn das Hilfethema online nicht gefunden wird. Scheint aber nicht wirklich die Ursache deines Problems zu sein. Ich denke, die Installation von WinHlp32.exe wird daran nichts ändern, da sich dieses Update auf die alten CHM-Hilfedateien beziehen.

    Frage 1: Hast Du zufällig Windows 7 über eine Beta oder RC1 installiert? Dann mache eine Clean-Installation.

    Frage 2: Was ist denn an Zusatzsoftware (Kamera und Handy-Suites) installiert?

    Frage 3: Ist bei Dir irgend eine Bluetooth-Lösung eines Fremdherstellers (nicht der Win 7-Bluetooth-Stack) installiert? Falls ja, probiere mal folgendes:

    [Zitat aus http://social.technet.microsoft.com/Forums/en-US/w7itprogeneral/thread/4e6f46f2-f4c2-40ea-9b54-973f019dcdf5]

    Here is the solution, I found after long time research.It`s caused by bluetooth software. I had the same "elbauser" corroptud help file. After you do this you`ll have windows original offline help files. If you have bluetooth in your pc, this is pretty much %100 problem causing help files to be corrupted.
    1. Click on Start, type regedit.exe in the Search field, and press Enter.
    2. Provide consent to User Account Control if prompted.
    3. In the left hand navigation pane, expand each registry key until you are at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Assistance\C lient\1.0\Namespaces\OEM\en-US\Topics.
    4. Delete the "BCRM_Bluetooth_Help" string value (REG_SZ).
    5. Close the Registry Editor and re-launch Windows Help and Support.

    [/Zitatat]

    Vielleicht hilft's - gibt auf jeden Fall mal eine Rückmeldung, wäre dann wohl für die Community interessant, da der _elbasuser- ziemlich häufig rumspuckt.

    PS: Gibt hier noch einen 2. Tread http://www.vistaheads.com/forums/microsoft-public-windows-vista-general/17424-help-support-not-working.html - wo jemand ähnliche Probleme unter Vista hat. Dort scheinen Zugriffsrechte eine Rolle zu spielen.


    Gruß, G. Born - Blogs: http://blog.borncity.com
    Donnerstag, 3. Dezember 2009 09:26

Alle Antworten

  • Wenn ich es richtig mit bekommen habe, gibt es einen Bug in der Hilfe, die besagte Fehlermeldung bringt, wenn das Hilfethema online nicht gefunden wird. Scheint aber nicht wirklich die Ursache deines Problems zu sein. Ich denke, die Installation von WinHlp32.exe wird daran nichts ändern, da sich dieses Update auf die alten CHM-Hilfedateien beziehen.

    Frage 1: Hast Du zufällig Windows 7 über eine Beta oder RC1 installiert? Dann mache eine Clean-Installation.

    Frage 2: Was ist denn an Zusatzsoftware (Kamera und Handy-Suites) installiert?

    Frage 3: Ist bei Dir irgend eine Bluetooth-Lösung eines Fremdherstellers (nicht der Win 7-Bluetooth-Stack) installiert? Falls ja, probiere mal folgendes:

    [Zitat aus http://social.technet.microsoft.com/Forums/en-US/w7itprogeneral/thread/4e6f46f2-f4c2-40ea-9b54-973f019dcdf5]

    Here is the solution, I found after long time research.It`s caused by bluetooth software. I had the same "elbauser" corroptud help file. After you do this you`ll have windows original offline help files. If you have bluetooth in your pc, this is pretty much %100 problem causing help files to be corrupted.
    1. Click on Start, type regedit.exe in the Search field, and press Enter.
    2. Provide consent to User Account Control if prompted.
    3. In the left hand navigation pane, expand each registry key until you are at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Assistance\C lient\1.0\Namespaces\OEM\en-US\Topics.
    4. Delete the "BCRM_Bluetooth_Help" string value (REG_SZ).
    5. Close the Registry Editor and re-launch Windows Help and Support.

    [/Zitatat]

    Vielleicht hilft's - gibt auf jeden Fall mal eine Rückmeldung, wäre dann wohl für die Community interessant, da der _elbasuser- ziemlich häufig rumspuckt.

    PS: Gibt hier noch einen 2. Tread http://www.vistaheads.com/forums/microsoft-public-windows-vista-general/17424-help-support-not-working.html - wo jemand ähnliche Probleme unter Vista hat. Dort scheinen Zugriffsrechte eine Rolle zu spielen.


    Gruß, G. Born - Blogs: http://blog.borncity.com
    Donnerstag, 3. Dezember 2009 09:26
  • Herr Born,
    vielen Dank für die rasche Antwort!

    Zu Ihren Fragen:
    - zu Frage 1: Ich habe Windows 7 nicht über eine Beta oder RC1 installiert. Ich habe Vista auf Windows 7 upgegraded.
    - zu Frage 2: Zusatzsoftware habe ich zahlreich installiert, Kamera und Handy-Suites jedoch keine. Es sei denn, die "Microsoft Live Cam" (für meine Web-Cam) ist ein solches Programm. Außerdem synchronisiere ich einen HP PDA mit Windows Mobile mit meinem PC.
    - zu Frage 3: Ist mir nicht bekannt.

    Zu Bluetooth habe ich folgendes versucht herauszufinden:
    Ich habe einen HP Pavilion Elite m9065.de Desktop-PC. Der hat eine kabellose Tastatur mit einem USB-Empfänger. Ob die Signale über Bluetooth oder über Funk übertragen werden, konnte ich nicht herausfinden. Die HP-Datenblätter geben da nichts her.
    Ich habe meine Registry nach "Bluetooth" durchsucht. Unter der Fülle an Einträgen sind vielleicht folgende von Bedeutung (ich bin allerdings kein Registry-Experte):
    - ObexDevice_SCMBluetoothManager.1,
    - WindowsMobile\wmdcBase.exe (Smartphone, Pocket PC u.a.),
    - Microsoft Bluetooth HID Miniport,
    - Blutooth Unterstützungsdienst.

    Zu dem Tip, im Registry-Pfad "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Assistance\C lient\1.0\Namespaces\OEM\en-US\Topics." den BCRM-Bluetooth_Help-Eintrag zu löschen:
    1.) "...\en-US\..." gibt es bei mir nicht, dort steht natürlich "...\de-DE\...".
    2.) Unter "...OEM\de-DE\Titles gibt es einen Eintrag "hp.npc.prjSolutions_de-DE" vom Typ REG_SZ und keinem Eintrag unter Daten.
    Da es keinen "BCRM-Bluetooth_Help"-Eintrag gibt, kann ich diesen auch nicht löschen. Insofern hilft dieser Tip nicht weiter.

    Mein "Hilfe-Problem" ist also nach wie vor ungelöst!

    Mit freundlichen Grüßen
    Jürgen Krebs

    Donnerstag, 3. Dezember 2009 16:04
  • Ich tippe aber schon darauf, dass die Update-Installation über Vista das Problem verursacht. Die angegebene Fundstelle bezieht sich natürlich auf eine spezielle Konfiguration des Betreffenden. Hier http://windows7forums.com/windows-7-software/24981-where-my-help-support.html gibt es eine ähnliche Diskussion (wobei der gleiche Poster auf ein Update der Broadcom-BT-Software hinweist). Mal ggf. schauen, ob da was von Broadcom auf dem System ist. Hab hier gerade mal eine Suche durchführen lassen - auf einem Standard Windows 7-System hat Regedit nichts zu Broadcom gefunden. Zweitens Suchmuster könnte noch Toshiba sein, die auch einen BT-Stack bereitstellen. Wird etwas gefunden, mal probieren, ob sich die betreffende SOftware noch deinstallieren lässt.

    Wenn das nicht hilft, wird es natürlich schwierig. In entsprechenden Fällen würde ich i.d.R. auf einen Clean-Install zurückgreifen (zumindest, wenn nicht schnell eine andere Lösung greift) - alles anderes ist meist "vertane Zeit".


    Gruß, G. Born - Blogs: http://blog.borncity.com
    Donnerstag, 3. Dezember 2009 20:01
  • Vielen Dank für die Antwort!
    Ich habe weder Software von Broadcom noch von Toshiba auf meinem PC installiert.

    In dem angegebenen Link zum Windows7-Forum habe ich folgende Aussage gefunden:
    "If none of the above related to you, think of a friend who has the same os with you and go in to windows help files in directory copy them to a usb storage then replace it with your originals."

    Das führt mich zu den beiden folgenden Fragen:
    - In welchem Verzeichnispfad befinden sich die Windows-Hilfe-Dateien?
    - Können diese nicht im Original für Windows 7 von Microsoft zum Download zur Verfügung gestellt werden?

    Denn nach meinen Recherchen im Internet haben doch wohl sehr viele Anwender das "__elbasuer__"-Problem mit der Windows-Hilfe!!!

    Mein "Hilfe-Problem" ist nach wie vor ungelöst!

    Als Microsoft Flight Simulator X-Enthusiast scheue ich aufgrund der sehr zahlreich installierten AddOns und Zusatzprogramme eine Neuinstallation (Clean-Install).
    Da ist mir dann doch eine fehlerhafte Windows-Hilfe noch eher akzeptabel.

    Aber vielleicht gibt es ja doch noch eine andere Lösung!?

    Mit freundlichen Grüßen
    Jürgen Krebs

    Freitag, 4. Dezember 2009 15:40
  • Bingo:) Das ist es. Der Reg. Eintrag. Schlüssel in de-DE gelöscht und es geht wieder:)

    Danke für den klasse Beitrag.

    Peter
    Samstag, 12. Dezember 2009 13:56
  • Hallo Peter,
    das habe ich jetzt nicht verstanden!

    Welchen Schlüssel hast Du in welchem Registry-Eintrag gelöscht? Und was war der "klasse Beitrag"? Der zu Bluetooth von G. Born?

    Ohne diese Angaben kann ich nicht prüfen, ob es bei mir auch hilft.

    Mit freundlichen Grüßen
    Jürgen Krebs 
    Sonntag, 13. Dezember 2009 10:12
  • Hallo Jürgen,
    ja der Beitrag von GBorn ist gemeint. Und zwar das hier:
    Here is the solution, I found after long time research.It`s caused by bluetooth software. I had the same "elbauser" corroptud help file. After you do this you`ll have windows original offline help files. If you have bluetooth in your pc, this is pretty much %100 problem causing help files to be corrupted.
    1. Click on Start, type regedit.exe in the Search field, and press Enter.
    2. Provide consent to User Account Control if prompted.
    3. In the left hand navigation pane, expand each registry key until you are at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Assistance\C lient\1.0\Namespaces\OEM\en-US\Topics.
    4. Delete the "BCRM_Bluetooth_Help" string value (REG_SZ).
    5. Close the Registry Editor and re-launch Windows Help and Support.
    Nur heisst es unter Punkt 3 en-US\Topics. Den gibt es aber nicht. Der Schlüssel heisst korrekt: de-DE\Titles. Dort findest du "BCRM_Bluetooth_Help".
    Ich habe ´
    "BCRM_Bluetooth_Help" gelöscht. Danach ist die Windows Hilfe wieder benutzbar.
    Registry VORHER SICHERN!

    Grüsse
    Peter

    Montag, 14. Dezember 2009 09:21
  • Hallo Peter,
    vielen Dank für Deine Antwort. Das habe ich jetzt verstanden und es ist schön, dass es Dir geholfen hat.
    Mir allerdings hilft es leider nicht, da ich den Eintrag "BCRM_Bluetooth_Help" in meiner Registry gar nicht habe (siehe meinen Beitrag vom 3. Dezember)..

    Mein Problem ist also nach wie vor ungelöst!

    Viele Grüße
    Jürgen
    Montag, 14. Dezember 2009 09:51
  • Hallo,

    wollte eben zum ersten mal Hilfe und Support verwenden und hab das selbe Problem.
    Auch habe ich den Eintrag nicht in der Regestry nicht.

    Vielleicht weiss ja noch jemand was.

    Vielen Dank
    Montag, 21. Dezember 2009 07:26
  • OK, noch ein Versuch. Schaut mal in diesen Artikel  und geht die beschriebenen Maßnahmen durch. Jürgen, schau dir vor allem meinen Hinweis auf die Zuordnung des XML-Handlers in HKEY_CLASSES_ROOT an. Würde mich interessieren, was bei dir da so steht und ob eine Anpassung dies behebt. Falls es die Lösung ist, würde mich interssieren, ob bei dir ältere Adobe Software installiert war.
    Gruß, G. Born - Blogs: http://blog.borncity.com
    Mittwoch, 23. Dezember 2009 11:17
  • Herr Born,
    danke für den erneuten Versuch, Hilfestellung zu leisten. Wegen Weihnachten kommt meine Antwort etwas verspätet. Dafür bitte ich um Verständnis.

    1. Die Zuordnung des XML-Handlers in HKEY_CLASSES_ROOT in meiner Registry ist genauso, wie in Ihrem Hilfe-Blog beschrieben. Ich brauchte sie also nicht in die Registry zu importieren.

    2. Da ich seit vielen Jahren mit verschiedenen PC gearbeitet habe, gab es natürlich früher auch Installationen von älteren Versionen des Adobe Acrobat Reader. Auf meinem derzeitigen PC, auf dem ich das Betriebssystem von VISTA auf Windows 7 upgegraded habe, ist allerdings nur der Adobe Reader 9 installiert. Andere Adobe Software gibt es bei mir keine.

    Mit freundlichen Grüßen
    Jürgen Krebs

    Dienstag, 29. Dezember 2009 09:48
  • Hallo Herr Krebs,
     
    Vielen Dank für Ihre Frage und Ihren Beitrag!

    Bitte haben Sie Verständnis dafür, dass wir uns hier in einem Software-Entwickler-Forum von MSDN Online, dem Microsoft Developer Network, befinden. 
    Ihre Frage betrifft ein Thema, das am besten und schnellsten in den Microsoft Answers Foren betreut werden kann, da IhreFrage nicht entwicklerspezifisch ist. Bitte folgen Sie dem unten stehenden Link, um IhreFrage in der Microsoft Answers Community erneut zu stellen.
     
    Microsoft Answers Forum für Deine Anfrage: Microsoft Answers: Windows 7

    Eine Übersicht über alle verfügbaren Microsoft Foren finden Sie unter http://www.microsoft.de/Community/Foren
    Eine Übersicht über alle verfügbaren Microsoft Hilfe & Support-Angebot finden Sie unter http://www.msdn-support.de  

    Wir danken Ihnen für Ihr Verständnis!
    Viele Grüße,
    Kay


    This post is powered by www.Giza-Blog.de | Sie besuchen MSDN heute zum ersten Mal?
    MSDN Online | Follow MSDN Online on Twitter | Follow Kay Giza on Twitter
    Tagesaktuelle News & Infos für Entwickler finden Sie auf MSDN Aktuell
    ~~ So melden Sie Forum-Probleme, -Bugs oder -Verbesserungsvorschläge ~~
    Samstag, 3. Juli 2010 06:53