none
[GELÖST] Bei der Weitergabe des Befehls an das Programm ist ein Fehler aufgetreten

    Frage

  • Guten Tag alle zusammen.
    Ich habe seit einiger Zeit das Problem, dass ich keine einzelnen Dateien mehr in Visual Studio öffnen kann.
    Es erscheint immer folgende Meldung:
    "Bei der Weitergabe des Befehls an das Programm ist ein Fehler aufgetreten."
    Beobachtet habe ich das Verhalten bei XML-, CS- und VB-Dateien.
    Ist Visual Studio jedoch bereits offen, so geschieht dies nicht. Auch Projektmappen und Projekte lassen sich problemlos öffnen.
    Habt ihr eine Idee? Oder einen Link, den ich zu blöd war zu "ergoogeln"?

    Ich freue mich auf Antworten.

    Viele Grüße, Phil940.

    PS: Es handelt sich um Visual Studio 2008 Prof. und Windows 7 Prof. 64-Bit.

    EDIT: Gelöst.

    Viele Grüße, Philipp.
    • Bearbeitet Phil940 Samstag, 12. Dezember 2009 23:04 Lösung gefunden
    Freitag, 11. Dezember 2009 23:13

Antworten

  • Nach langem experimentieren habe ich nun eine Lösung gefunden.
    Man muss bei jedem Dateityp, der Visual Studio mit dem Parameter /dde öffnet, in der Registry diesen Parameter entfernen.
    Dann läuft es ganz normal, also einzelne Dateien werden als neue Tabs in VS geöffnet.
    Allerdings ist es komisch, dass es mit /dde nicht geht, ohne aber schon.

    Viele Grüße, Philipp.
    • Als Antwort markiert Phil940 Samstag, 12. Dezember 2009 23:05
    Samstag, 12. Dezember 2009 23:05

Alle Antworten

  • Nach langem experimentieren habe ich nun eine Lösung gefunden.
    Man muss bei jedem Dateityp, der Visual Studio mit dem Parameter /dde öffnet, in der Registry diesen Parameter entfernen.
    Dann läuft es ganz normal, also einzelne Dateien werden als neue Tabs in VS geöffnet.
    Allerdings ist es komisch, dass es mit /dde nicht geht, ohne aber schon.

    Viele Grüße, Philipp.
    • Als Antwort markiert Phil940 Samstag, 12. Dezember 2009 23:05
    Samstag, 12. Dezember 2009 23:05
  • Hallo Philipp,

    habe das gleiche Problem: Bei der Weitergabe,...

    Nur bei CorelDraw4X. Mit Win7 pro 64 bit.

    Hier geht es um .cdr Dateien, bzw jpg, tif usw.

    Habe leider in der Registry(start-ausführen-regedit) bei hkey_classes_root nichts mit /dde bei .cdr gefunden. Nur diese beiden Unterordner waren vorhanden: PersistentHandler  ShellNew hier leider auch nichts mit -DDE

    Die einzigen -DDE habe ich bei 

    CorelDRAW.Graphic.14 unter dem Ordner: shell/Import, shell/print to, shell/open, shell/print jeweils im Unterordner command gefunden:

    "c:\Program Files (x86)\Corel\CorelDRAW Graphics Suite X4\PROGRAMS\CORELDRW.EXE" -DDE

    Dieses -DDE zu löschen brachte leider nichts.

    Unter den jeweiligen Ordnern Import / Print / Print to / Open   war auch immer ein Ordner ddeexec\application mit einem Wert CorelDRAW_MOS / Typ: REG_SZ / Name: Standard 

    Irgendwelche Ideen oder habe ich nicht das richtige -DDE gefunden ?

    Vielen Dank schon einmal fürs lesen und eventuelle Antworten.

    Ralph

    Montag, 8. Juli 2013 00:29
  • Hey,

    ich hatte in Visual Studio 2013 Premium nun das gleiche Problem.
    Da ich das Problem mit meinen C-Dateien hatte, habe ich mir in der Registry den folgenden Schlüssel gesucht:

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\VisualStudio.c.12.0\shell\Open\Command

    hier habe ich die Daten von

    "C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\devenv.exe" /dde

    zu 

    "C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\devenv.exe" "%1"

    geändert.
    Da nun die Dateien geöffnet wurden, aber trotzdem jedesmal der Fehler hochkam, habe ich den folgenden Schlüssel sowie dessen Unterschlüssel gelöscht:

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\VisualStudio.c.12.0\shell\Open\ddeexec

    Zwar wird nun für jede c-Datei ein eigenes Fenster geöffnet, aber damit kann ich leben, da es ja nur zur kurzen Ansicht der Datei ist.

    Hoffe ich konnte helfen.

    Andy


    Freitag, 11. April 2014 06:52