none
Fehler im Pfad zu den Libraries

    Frage

  • Ich arbeite mit openFrameWorks 0.8.0 in Visual Studio 2012 Express.
    Seit einer Neuinstallation von Visual Studio werden sämtliche Funktionen und Objekte von openFrameWorks nicht mehr gefunden. 
    Es scheint als habe sich das Root Verzeichnis bei allen Projekten (auch bei den Examples) duch irgendeine Einstellung in Visual Studio verändert. Wenn ich zB. ein zusätzliches Includeverzeichnis in den Projekteinstellungen hinzufüge gehe ich normalerweise mit ../../../ drei Verzeichnisse nach oben und befinde mich dann in meinem Projektverzeichnis (von dort aus geht's dann zu den Libraries). Seltsamerweise befinde ich micht beim ersten ../ nicht in meinem Projektverzeichnis eine Hierachie höher, sondern befinde mich plötzlich in C:/Windows/
    Das erklärt, warum zusätzlichen Dateien nicht gefunden werden. 
    Ich finde leider nur nirgendwo eine Einstellung, um festzulegen, dass alle Pfade (wie es normal immer war) vom /bin oder /src Verzeichnis aus gehen.

    Ich habe alle Optionen auf der Projekt Eigenschaftenseite mit einem anderen Computer, bei dem die Links funktionieren verglichen, aber kein unterschieden gefunden. 

    Vielen Dank für Hinweise, wie ich in VisualStudio die Einstellungen zurücksetzen kann.

    Freitag, 24. Januar 2014 17:20

Antworten

  • Jack Zhai hat im hat im Englisch sprachigen Forum geschrieben, wie sich die Einstellungen resetten lassen:

    1. On the Tools menu (Extras), click Import and Export Settings.
    2. On the Welcome to the Import and Export Settings Wizard page, click Reset all settings and then click Next.
    3. If you want to save your current settings combination, click Yes, save my current settings, specify a file name, and then click Next.

    Ein anschließendes Update auf Visual Studio 2014 4.5 hat den Rest der Probleme behoben.

    Siehe Question: Error in path to libraries (einraum.design)

    Mittwoch, 29. Januar 2014 15:29

Alle Antworten