locked
Not able to configuration Test Agent.

    Dotaz

  • I have installed test controller on my TFS machine and tried installing Test Agent on my (client) machine where MTM is available, it throws an error “Failed to register this test agent with the test controller..…”. My systems are in work group, does it create any problem?

    Because of this problem I am not able to configure “Lab Management” and not able to run coded UI test as well. Is there any work around for this problem?

    18. října 2010 15:20

Všechny reakce

  • Since the machines on which test agent is getting installed are in work group and there is no trust between test controller and test agent.

    Solution to this is shadow account:

    Step1: Create an local account on Test controller (say User1 with password Pass1 ) and add this to local groups: "TeamTestAgentService" and "TeamTestControllerUsers"

    Step2: Create local account on test agent same as above account.

    Step3: Now use this account to configure and run test agent configuration tool. Test agent service should be running with this account.

    Lab Management solves this problem for virtual environment by setting lab service account during lab Management configuration on TFS Admin Console [http://msdn.microsoft.com/en-us/vstudio/gg131911.aspx ]

    One just need to install test agent on virtual templates and TFS takes care of configuring test agent using lab service account on work group as well as domain joined virtual machines.

    More info @http://blogs.msdn.com/b/lab_management/archive/2010/02/22/what-is-lab-service-account.aspx

     

    19. října 2010 7:37
  • Tried Step1 to Step3 still face the same problem. Error log is as

    "Failed to register this test agent with the test controller. Possible reasons could be you do not have the right permissions to connect to the test controller 100.100.100.100:6901, the log on account does not exist on the test controller machine, or a firewall is blocking the connection.
    To fix this problem, verify that you are a local administrator on the test controller machine, that the log on account aatugade exists on the test controller machine, and that the Windows Firewall Settings on the test controller machine has "File and Printer Sharing" exception."

    19. října 2010 9:31
  • Rajesh,

    Can you please verify that you have done all the steps mentioned in the documentation here: http://msdn.microsoft.com/en-us/library/dd648127.aspx#Workgroups 

    I think you see the error because the account you use to run the agent configuration tool is not an Administrator (member of Administrators group) on the controller machine. Please add the shadow account as administrator on both agent and controller, use the same account to configure the test agent with controller and as the test agent service account. I think that should solve your problem. Please let me know if it doesnt.

    Thanks.

    -Darshan

    19. října 2010 10:27
  • Hi Darshan,

     

    Tried all those options, created new user named "testuser" on both controller and agent machine with admin rights. User on controller machine is added to TeamTestAgentSevere, TeamTestControllerAdmins, TeamTestControllerUsers and Administrators Groups. User on agent machine is added to Administrators Groups.

     

    Please see the entire log below...



    **************************************************************************************


    Configuration started on 2010/10/19, 15:10:38.
    OS Version : Microsoft Windows NT 5.1.2600 Service Pack 3
    Executable version : 10.0.30319.1

    I, 2010/10/19, 15:10:38.167, Listing agent configurations
    I, 2010/10/19, 15:10:39.057, GetControllerName : The controller name managed by lab is
    I, 2010/10/19, 15:10:39.370, IsManagedByLab : lab manaaged controller name :
    I, 2010/10/19, 15:10:39.370, NotManagedByLab = True
    I, 2010/10/19, 15:11:49.698, Checking whether account testuser is a network service

    account or not
    V, 2010/10/19, 15:11:49.713, Created Nt account testuser for userName testuser
    V, 2010/10/19, 15:11:49.745, Found Sid S-1-5-21-183494139-125219725-682368907-1021 for

    userName testuser
    I, 2010/10/19, 15:11:49.745, Observed that account testuser is network service

    account? False
    I, 2010/10/19, 15:11:49.760, Domain:
    I, 2010/10/19, 15:11:49.760, Final UserName: RAJESH\testuser.
    I, 2010/10/19, 15:11:49.760, Loading account details for RAJESH\testuser
    I, 2010/10/19, 15:11:49.776, Normalized account is RAJESH\testuser and Sid is S-1-5-

    21-183494139-125219725-682368907-1021
    I, 2010/10/19, 15:11:49.838, Agent configuration update pack details :
    I, 2010/10/19, 15:11:49.838, Run as interactive process : True
    I, 2010/10/19, 15:11:49.838, Network service name NT AUTHORITY\NETWORK SERVICE
    I, 2010/10/19, 15:11:49.854, User name : testuser
    I, 2010/10/19, 15:11:49.854, Change Port : False
    I, 2010/10/19, 15:11:49.854, Chang eService Account : True
    I, 2010/10/19, 15:11:49.854, Change Test Controller : True
    I, 2010/10/19, 15:11:49.854, Test Controller Uri : 100.100.100.100:6901
    I, 2010/10/19, 15:11:49.854, Disable Screensaver : False
    I, 2010/10/19, 15:11:49.854, Enable autologon : False
    I, 2010/10/19, 15:11:49.854, Port : -1
    I, 2010/10/19, 15:11:49.854, Checking whether account RAJESH\testuser is a network

    service account or not
    V, 2010/10/19, 15:11:49.854, Created Nt account RAJESH\testuser for userName

    RAJESH\testuser
    V, 2010/10/19, 15:11:49.854, Found Sid S-1-5-21-183494139-125219725-682368907-1021 for

    userName RAJESH\testuser
    I, 2010/10/19, 15:11:49.854, Observed that account RAJESH\testuser is network service

    account? False
    I, 2010/10/19, 15:11:49.854, Domain: RAJESH
    I, 2010/10/19, 15:11:49.854, Final UserName: RAJESH\testuser.
    I, 2010/10/19, 15:11:49.854, Loading account details for RAJESH\testuser
    I, 2010/10/19, 15:11:49.854, Normalized account is RAJESH\testuser and Sid is S-1-5-

    21-183494139-125219725-682368907-1021
    I, 2010/10/19, 15:11:49.963, Starting firewall configuration...
    I, 2010/10/19, 15:11:50.120, BaseConfig: AddFirewallExceptionIfRequired: Adding

    Port=6910,Description=Microsoft Visual Studio Test Agent 2010 Service in firewall

    exceptions.
    I, 2010/10/19, 15:11:50.135, BaseConfig: AddFirewallExceptionIfRequired: Added

    Port=6910,Description=Microsoft Visual Studio Test Agent 2010 Service in firewall

    exceptions.
    I, 2010/10/19, 15:11:50.135, Configured firewall exceptions for: 'Microsoft Visual

    Studio Test Agent 2010 Service'.
    I, 2010/10/19, 15:11:50.135, Adding agent setting

    Microsoft.TeamFoundation.Lab.TestIntegration.AgentVersion=2.0.0 on agent machine
    I, 2010/10/19, 15:11:50.135, Adding agent setting

    Microsoft.TeamFoundation.Lab.TestIntegration.AgentVersion=2.0.0 on agent machine - 32

    bit hive
    I, 2010/10/19, 15:11:50.135, Creating Key: EnterpriseTools\QualityTools\Agent
    I, 2010/10/19, 15:11:50.182, Added agent setting

    Microsoft.TeamFoundation.Lab.TestIntegration.AgentVersion=2.0.0 on agent machine - 32

    bit hive
    I, 2010/10/19, 15:11:50.182, Adding agent setting

    Microsoft.TeamFoundation.Lab.TestIntegration.AgentVersion=2.0.0 on agent machine - 64

    bit hive
    I, 2010/10/19, 15:11:50.198, Added agent setting

    Microsoft.TeamFoundation.Lab.TestIntegration.AgentVersion=2.0.0 on agent machine - 64

    bit hive
    I, 2010/10/19, 15:11:50.198, Adding agent setting

    Microsoft.TeamFoundation.Lab.TestIntegration.AgentContractVersion=2 on agent machine
    I, 2010/10/19, 15:11:50.198, Adding agent setting

    Microsoft.TeamFoundation.Lab.TestIntegration.AgentContractVersion=2 on agent machine -

    32 bit hive
    I, 2010/10/19, 15:11:50.198, Added agent setting

    Microsoft.TeamFoundation.Lab.TestIntegration.AgentContractVersion=2 on agent machine -

    32 bit hive
    I, 2010/10/19, 15:11:50.198, Adding agent setting

    Microsoft.TeamFoundation.Lab.TestIntegration.AgentContractVersion=2 on agent machine -

    64 bit hive
    I, 2010/10/19, 15:11:50.198, Added agent setting

    Microsoft.TeamFoundation.Lab.TestIntegration.AgentContractVersion=2 on agent machine -

    64 bit hive
    I, 2010/10/19, 15:11:50.198, Adding agent setting InstallationPath=C:\Program

    Files\Microsoft Visual Studio 10.0\Common7\IDE on agent machine
    I, 2010/10/19, 15:11:50.198, Adding agent setting InstallationPath=C:\Program

    Files\Microsoft Visual Studio 10.0\Common7\IDE on agent machine - 32 bit hive
    I, 2010/10/19, 15:11:50.198, Added agent setting InstallationPath=C:\Program

    Files\Microsoft Visual Studio 10.0\Common7\IDE on agent machine - 32 bit hive
    I, 2010/10/19, 15:11:50.198, Adding agent setting InstallationPath=C:\Program

    Files\Microsoft Visual Studio 10.0\Common7\IDE on agent machine - 64 bit hive
    I, 2010/10/19, 15:11:50.198, Added agent setting InstallationPath=C:\Program

    Files\Microsoft Visual Studio 10.0\Common7\IDE on agent machine - 64 bit hive
    I, 2010/10/19, 15:11:50.213, Creating event sources VSTTAgent
    I, 2010/10/19, 15:11:50.213, Creating event sources VSTTAgent
    I, 2010/10/19, 15:11:51.104, Created event source VSTTAgent
    I, 2010/10/19, 15:11:51.104, Creating event sources VSTTAgentProcess
    I, 2010/10/19, 15:11:51.104, Event source VSTTAgentProcess already exists.
    I, 2010/10/19, 15:11:51.104, Adding event source for event logging
    I, 2010/10/19, 15:11:51.104, ResetForceGuestKey : Getting the value of ForceGuest key
    I, 2010/10/19, 15:11:51.104, ResetForceGuestKey : The value of ForceGuest key is 0
    I, 2010/10/19, 15:11:51.120, Checking the status of service VSTTAgent
    I, 2010/10/19, 15:11:51.151, Found that service VSTTAgent is installed:False
    I, 2010/10/19, 15:11:51.167, Configuring test agent process...
    I, 2010/10/19, 15:11:51.167, Checking whether account RAJESH\testuser is a network

    service account or not
    V, 2010/10/19, 15:11:51.167, Created Nt account RAJESH\testuser for userName

    RAJESH\testuser
    V, 2010/10/19, 15:11:51.167, Found Sid S-1-5-21-183494139-125219725-682368907-1021 for

    userName RAJESH\testuser
    I, 2010/10/19, 15:11:51.167, Observed that account RAJESH\testuser is network service

    account? False
    I, 2010/10/19, 15:11:51.167, Domain: RAJESH
    I, 2010/10/19, 15:11:51.167, Final UserName: RAJESH\testuser.
    I, 2010/10/19, 15:11:51.167, Loading account details for RAJESH\testuser
    I, 2010/10/19, 15:11:51.167, Normalized account is RAJESH\testuser and Sid is S-1-5-

    21-183494139-125219725-682368907-1021
    I, 2010/10/19, 15:11:51.167, Adding the process as startup program for user

    RAJESH\testuser...
    I, 2010/10/19, 15:11:51.167, Updating the startup registry
    I, 2010/10/19, 15:11:51.167, Updating Run registry to value : C:\Program

    Files\Microsoft Visual Studio 10.0\Common7\IDE\QTAgentProcessUI.exe
    I, 2010/10/19, 15:11:51.167, Adding agent setting DisableScreenSaver=False on agent

    machine
    I, 2010/10/19, 15:11:51.167, Adding agent setting DisableScreenSaver=False on agent

    machine - 32 bit hive
    I, 2010/10/19, 15:11:51.182, Added agent setting DisableScreenSaver=False on agent

    machine - 32 bit hive
    I, 2010/10/19, 15:11:51.182, Adding agent setting DisableScreenSaver=False on agent

    machine - 64 bit hive
    I, 2010/10/19, 15:11:51.182, Added agent setting DisableScreenSaver=False on agent

    machine - 64 bit hive
    I, 2010/10/19, 15:11:51.182, Adding agent setting AgentRunMode=AsInteractiveProcess on

    agent machine
    I, 2010/10/19, 15:11:51.182, Adding agent setting AgentRunMode=AsInteractiveProcess on

    agent machine - 32 bit hive
    I, 2010/10/19, 15:11:51.182, Added agent setting AgentRunMode=AsInteractiveProcess on

    agent machine - 32 bit hive
    I, 2010/10/19, 15:11:51.182, Adding agent setting AgentRunMode=AsInteractiveProcess on

    agent machine - 64 bit hive
    I, 2010/10/19, 15:11:51.182, Added agent setting AgentRunMode=AsInteractiveProcess on

    agent machine - 64 bit hive
    I, 2010/10/19, 15:11:51.182, Adding agent setting

    AgentInteractiveProcessUserName=RAJESH\testuser on agent machine
    I, 2010/10/19, 15:11:51.182, Adding agent setting

    AgentInteractiveProcessUserName=RAJESH\testuser on agent machine - 32 bit hive
    I, 2010/10/19, 15:11:51.198, Added agent setting

    AgentInteractiveProcessUserName=RAJESH\testuser on agent machine - 32 bit hive
    I, 2010/10/19, 15:11:51.198, Adding agent setting

    AgentInteractiveProcessUserName=RAJESH\testuser on agent machine - 64 bit hive
    I, 2010/10/19, 15:11:51.198, Added agent setting

    AgentInteractiveProcessUserName=RAJESH\testuser on agent machine - 64 bit hive
    I, 2010/10/19, 15:11:51.198, Configured test agent process successfully.
    I, 2010/10/19, 15:11:51.198, Setting Tcp Parameters
    V, 2010/10/19, 15:11:51.198, Setting Tcp Parameters in 32bit Hive
    V, 2010/10/19, 15:11:51.198, Setting Tcp Parameters in 32bit Hive completed.
    V, 2010/10/19, 15:11:51.198, Setting Tcp Parameters in 64bit Hive.
    V, 2010/10/19, 15:11:51.198, Setting Tcp Parameters in 64bit Hive completed.
    I, 2010/10/19, 15:11:51.198, Setting Tcp Parameters completed.
    I, 2010/10/19, 15:11:51.213, Registering this test agent with the test controller.

    This may take few minutes...
    I, 2010/10/19, 15:11:51.213, AgentConfiguration: Starting controller configuration.
    I, 2010/10/19, 15:11:51.213, GetControllerName : The controller name managed by lab is
    I, 2010/10/19, 15:11:51.213, GetControllerName : The controller name managed by lab is
    I, 2010/10/19, 15:11:51.213, AgentConfiguration: Found agent is not configured on any

    controller.
    I, 2010/10/19, 15:11:51.213, AgentConfiguration: Adding agent RAJESH on controller

    100.100.100.100:6901.
    I, 2010/10/19, 15:11:51.213, Adding agent RAJESH running under 100.100.100.100:6901 to

    controller RAJESH\testuser
    I, 2010/10/19, 15:11:51.698, Creating Channel
    I, 2010/10/19, 15:11:57.745, CreateControllerObject: attempt 0,

    System.Net.Sockets.SocketException (0x80004005): No such host is known

    Server stack trace:
       at System.Net.Dns.GetAddrInfo(String name)
       at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
       at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
       at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket()
       at System.Runtime.Remoting.Channels.RemoteConnection.GetSocket()
       at System.Runtime.Remoting.Channels.SocketCache.GetSocket(String machinePortAndSid,

    Boolean openNew)
       at

    System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.SendRequestWithRetry

    (IMessage msg, ITransportHeaders requestHeaders, Stream requestStream)
       at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.ProcessMessage

    (IMessage msg, ITransportHeaders requestHeaders, Stream requestStream,

    ITransportHeaders& responseHeaders, Stream& responseStream)
       at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage

    (IMessage msg)

    Exception rethrown at [0]:
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg,

    IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData,

    Int32 type)
       at Microsoft.VisualStudio.TestTools.Controller.ControllerObject.Hello()
       at

    Microsoft.VisualStudio.TestTools.ConfigCore.TestControllerHelper.CreateControllerObjec

    t(String controllerUri)
    I, 2010/10/19, 15:12:02.495, CreateControllerObject: attempt 1,

    System.Net.Sockets.SocketException (0x80004005): No such host is known

    Server stack trace:
       at System.Net.Dns.GetAddrInfo(String name)
       at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
       at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
       at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket()
       at System.Runtime.Remoting.Channels.RemoteConnection.GetSocket()
       at System.Runtime.Remoting.Channels.SocketCache.GetSocket(String machinePortAndSid,

    Boolean openNew)
       at

    System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.SendRequestWithRetry

    (IMessage msg, ITransportHeaders requestHeaders, Stream requestStream)
       at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.ProcessMessage

    (IMessage msg, ITransportHeaders requestHeaders, Stream requestStream,

    ITransportHeaders& responseHeaders, Stream& responseStream)
       at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage

    (IMessage msg)

    Exception rethrown at [0]:
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg,

    IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData,

    Int32 type)
       at Microsoft.VisualStudio.TestTools.Controller.ControllerObject.Hello()
       at

    Microsoft.VisualStudio.TestTools.ConfigCore.TestControllerHelper.CreateControllerObjec

    t(String controllerUri)
    I, 2010/10/19, 15:12:07.213, CreateControllerObject: attempt 2,

    System.Net.Sockets.SocketException (0x80004005): No such host is known

    Server stack trace:
       at System.Net.Dns.GetAddrInfo(String name)
       at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
       at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
       at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket()
       at System.Runtime.Remoting.Channels.RemoteConnection.GetSocket()
       at System.Runtime.Remoting.Channels.SocketCache.GetSocket(String machinePortAndSid,

    Boolean openNew)
       at

    System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.SendRequestWithRetry

    (IMessage msg, ITransportHeaders requestHeaders, Stream requestStream)
       at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.ProcessMessage

    (IMessage msg, ITransportHeaders requestHeaders, Stream requestStream,

    ITransportHeaders& responseHeaders, Stream& responseStream)
       at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage

    (IMessage msg)

    Exception rethrown at [0]:
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg,

    IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData,

    Int32 type)
       at Microsoft.VisualStudio.TestTools.Controller.ControllerObject.Hello()
       at

    Microsoft.VisualStudio.TestTools.ConfigCore.TestControllerHelper.CreateControllerObjec

    t(String controllerUri)
    E, 2010/10/19, 15:12:07.338,

    Microsoft.VisualStudio.TestTools.ConfigCore.ConfigToolException: Unable to connect to

    test controller service 100.100.100.100:6901
       at

    Microsoft.VisualStudio.TestTools.ConfigCore.TestControllerHelper.CreateControllerObjec

    t(String controllerUri)
       at Microsoft.VisualStudio.TestTools.ConfigCore.TestControllerHelper.AddAgent(String

    agentName, String controllerUri, ServiceAccount agentServiceAccount)
       at Microsoft.VisualStudio.TestTools.ConfigCore.AgentConfiguration.BindToController

    (String testController, ServiceAccount agentServiceAccount)
       at

    Microsoft.VisualStudio.TestTools.ConfigCore.AgentConfiguration.HandleControllerChange

    (AgentConfigurationUpdatePack updatePack, DelegateStatusUpdate statusListener)
    I, 2010/10/19, 15:12:07.338, DetermineDomain:: User: RAJESH\testuser
    I, 2010/10/19, 15:12:07.338, Domain: RAJESH
    I, 2010/10/19, 15:12:07.338, Machine Name: RAJESH
    I, 2010/10/19, 15:12:07.338, Final Domain: .  Final username: testuser
    E, 2010/10/19, 15:12:07.338, Failed to register this test agent with the test

    controller. Possible reasons could be you do not have the right permissions to connect

    to the test controller 100.100.100.100:6901, the log on account does not exist on the

    test controller machine, or a firewall is blocking the connection.
    To fix this problem, verify that you are a local administrator on the test controller

    machine, that the log on account testuser exists on the test controller machine, and

    that the Windows Firewall Settings on the test controller machine has "File and

    Printer Sharing" exception.

    I, 2010/10/19, 15:12:07.338, IsManagedByLab : lab manaaged controller name :
    I, 2010/10/19, 15:12:07.338, Adding agent account RAJESH\testuser on controller

    100.100.100.100:6901...
    I, 2010/10/19, 15:12:07.354, AgentConfiguration: Adding agent account RAJESH\testuser

    on controller 100.100.100.100:6901.
    V, 2010/10/19, 15:12:07.448, Adding agent service account RAJESH\testuser to

    TeamTestAgentService group on controller 100.100.100.100
    I, 2010/10/19, 15:12:07.651, Creating user RAJESH\testuser on machine 100.100.100.100
    V, 2010/10/19, 15:12:07.667, Created Nt account RAJESH\testuser for userName

    RAJESH\testuser
    V, 2010/10/19, 15:12:07.667, Found Sid S-1-5-21-183494139-125219725-682368907-1021 for

    userName RAJESH\testuser
    I, 2010/10/19, 15:12:07.667, Using machine$ account RAJESH\testuser on machine

    100.100.100.100
    I, 2010/10/19, 15:12:07.667, DetermineDomain:: User: RAJESH\testuser
    I, 2010/10/19, 15:12:07.667, Domain: RAJESH
    I, 2010/10/19, 15:12:07.667, Machine Name: RAJESH
    I, 2010/10/19, 15:12:07.667, Final Domain: .  Final username: testuser
    I, 2010/10/19, 15:12:13.979, DetermineDomain:: User: RAJESH\testuser
    I, 2010/10/19, 15:12:13.979, Domain: RAJESH
    I, 2010/10/19, 15:12:13.979, Machine Name: RAJESH
    I, 2010/10/19, 15:12:13.979, Final Domain: .  Final username: testuser
    V, 2010/10/19, 15:12:26.776, Added agent service account RAJESH\testuser to

    TeamTestAgentService group on controller 100.100.100.100
    I, 2010/10/19, 15:12:26.776, AgentConfiguration: Added agent account RAJESH\testuser

    on controller 100.100.100.100:6901.
    I, 2010/10/19, 15:12:26.776, Added agent user account RAJESH\testuser on controller

    100.100.100.100:6901 successfully.
    I, 2010/10/19, 15:12:26.776, Configuring ACL...
    I, 2010/10/19, 15:13:38.682, Configured ACL successfully.
    I, 2010/10/19, 15:13:38.729, GetControllerName : The controller name managed by lab is
    I, 2010/10/19, 15:13:38.745, Starting test agent process...
    W, 2010/10/19, 15:13:38.745, Test agent process is not started as it is not associated

    with any test controller. Ignore this warning if this machine will be used in a

    virtual environment created using the Lab Center of Microsoft Test Manager.
    I, 2010/10/19, 15:13:38.745, Controller Machine = 100.100.100.100, Agent Machine =

    RAJESH
    I, 2010/10/19, 15:13:38.745, IsAdminAccount : Trying to determine if the account :

    RAJESH\testuser is an admin on the local machine
    I, 2010/10/19, 15:13:38.760, Configuring network emulation driver. This may take few

    minutes...
    I, 2010/10/19, 15:13:38.760, Started checking the status of the Network Emulation

    Driver.
    I, 2010/10/19, 15:13:38.760, Network Emulation driver is not installed, attempting to

    install it now.
    I, 2010/10/19, 15:13:38.760, Installing new Network Emulation driver.
    I, 2010/10/19, 15:13:38.760, Operating System Check: Microsoft Windows NT 5.1.2600

    Service Pack 3 (32 Bit)
    I, 2010/10/19, 15:13:38.760, Check for existing driver: Done.
    I, 2010/10/19, 15:13:38.776, Driver installation files check: Done.
    I, 2010/10/19, 15:13:39.135, Network test passed.
    I, 2010/10/19, 15:13:39.135, Installing the Network Emulation driver...
    I, 2010/10/19, 15:14:11.276, Driver installation: Done.
    I, 2010/10/19, 15:14:11.276, Testing driver...
    I, 2010/10/19, 15:14:11.276, Driver version check: Done.
    I, 2010/10/19, 15:14:11.276, Testing driver bindings...
    I, 2010/10/19, 15:14:11.307, Driver is bound to 4 NIC(s)
    I, 2010/10/19, 15:14:11.307, Testing driver initialization...
    I, 2010/10/19, 15:14:11.307, Driver initialization: Succeeded.
    I, 2010/10/19, 15:14:11.307, Waiting for the network to return...
    I, 2010/10/19, 15:14:15.463, Network test passed.
    I, 2010/10/19, 15:14:15.479, The Network Emulation driver was installed successfully.
    I, 2010/10/19, 15:14:15.573, Network Emulation driver is now installed and configured.
    I, 2010/10/19, 15:14:15.573, Checking whether account RAJESH\testuser is a network

    service account or not
    V, 2010/10/19, 15:14:15.573, Created Nt account RAJESH\testuser for userName

    RAJESH\testuser
    V, 2010/10/19, 15:14:15.573, Found Sid S-1-5-21-183494139-125219725-682368907-1021 for

    userName RAJESH\testuser
    I, 2010/10/19, 15:14:15.573, Observed that account RAJESH\testuser is network service

    account? False
    I, 2010/10/19, 15:14:15.573, Domain: RAJESH
    I, 2010/10/19, 15:14:15.573, Final UserName: RAJESH\testuser.
    I, 2010/10/19, 15:14:15.573, Loading account details for RAJESH\testuser
    I, 2010/10/19, 15:14:15.573, Normalized account is RAJESH\testuser and Sid is S-1-5-

    21-183494139-125219725-682368907-1021

    ==============================================================================

    - Rajesh

     

     

    19. října 2010 11:17
  • Hi Darshan,

    I still struggling with this issue, could you provide me any solution to overcome this situation?

     

    -Rajesh

    26. října 2010 7:50
  • Hi Rajesh,

    The logs which you have shared contains the following error which seems to me the real reason for the failure.

    I, 2010/10/19, 15:11:57.745, CreateControllerObject: attempt 0,

    System.Net.Sockets.SocketException (0x80004005): No such host is known

     

    Can you please check whether the test agent machine is able to resolve the test controller machine (100.100.100.100)? You can check the resolution by opening a command prompt on the agent machine and doing a ping (ping 100.100.100.100) and see whether it works or not?

    Regards

    Aseem Bansal

    26. října 2010 10:36
  • I am able to ping test controller machine from my test agent machine. Both controller machine and agent machine are in work group do I need to make any other settings for that?


    26. října 2010 12:33
  • Hi Rajesh,

    This seems strange.

    Can you please share whether you used the controller machine name or its IPAddress in your ping test? If you used IPAddress, can you try with machine name as well?

    From the error message, I assumed that the name "100.100.100.100" in the configuration logs is refering to controller machine name and not its IP address. If the configuration logs contain IP address does the ping request to the machine name resolves to the same IP address or different one?

    Regards

    Aseem Bansal

    26. října 2010 12:41
  • I am able to ping with both IP address and Machine Name. I am able to open the port (telnet) from test agent machine too.
    26. října 2010 14:14
  • Hmm..

    1. I am assuming that you ran the configuration tool on 19th and today when ping worked, you did not try configuring it again , Right? If yes, can you please try running the configuration tool again and see whether it works or not. If it does not work, can you please paste the logs again?

    2. If today with step 1, the configuration tool again fails with "no such host is known" error, can you please try using controller's IP address instead of controller's machine name in the configuration tool and see whether it works or not? If it also does not work, please paste these logs as well?

    Regards

    Aseem Bansal

    26. října 2010 14:54
  • Hi Aseem,

     

    I am able to ping controller with IP address and Machine name as well, but still Agent fails to connect..

    Tried posting the logs here but couldn't succeed...

    28. října 2010 11:46
  • You can send the logs directly to me at aseemb at microsoft dot com.

    Regards

    Aseem Bansal

    28. října 2010 13:53
  • Are you able to ping both ways (from controller to agent and vice-versa)? I am assuming that the password for "testuser" account is same on both machines.

     

    30. října 2010 3:00
  • Hi Gupta,

     

    Yes, username and passwards on Test controller and Test Agent are same. I am able to ping (and telnet) test agent to test controller, in both ways.

    2. listopadu 2010 9:58
  • Aseem Did you noticed this part of the log?

    Checking the status of service VSTTAgent
    Found that service VSTTAgent is installed:False

     

    I have a very different troubleshoot configuration, where everything is on the same machine, firewall is off the user belongs to all the indicated groups and the Test Agent Simply can't find the controller. What is happening here? Why does the model has to be so complicated?

    13. ledna 2011 19:53
  • Rajesh, How was this issue solved?

    I think I am having the same issue: http://social.msdn.microsoft.com/Forums/en-US/vstswebtest/thread/a89309a4-d1cc-420a-9a48-0397f4b5ec42

     

     

    • Navržen jako odpověď MerlinFloyd 15. února 2012 3:43
    • Zrušeno navržení jako odpověď MerlinFloyd 15. února 2012 3:44
    4. listopadu 2011 20:27
  • I had a similar problem.  I solved the problem by starting the test agent configuration tool and using "Run As..." the user account that I planned to use. 
    15. února 2012 3:46
  • I had the same issue and fixed after I added the shadow account in the administrator local group (besides "TeamTestAgentService" and "TeamTestControllerUsers") in test controller setup.

    totta wang

    24. února 2012 3:11
  • In case it helps anyone else, I eventually solved this problem by opening up TCP port 445 on my controller machine in the VMM firewall.  What I eventually discovered is that in addition to TCP port 6901, which the agents use to register with the controller, the agents and controller are attempting to do some communication over SMB/netbios.  By watching the network traffic and some searching, I found that this communication would work if I opened up TCP port 445 on ingress into by controller and agents machines in my below-the-OS firewall.

    I suspect that this is what is being done by the controller and agent services when they say "open the printer and sharing" firewall settings, but that only helped in the OS itself, since I was running in a virtualized environment where a firewall also existed below the OS, I didn't understand the implications of this part of the configuration.

    In summary, my VMM firewall allows TCP ports 6901 and 445 on ingress into the controller and agents.

    1. června 2012 21:58