locked
Debugger problem "The breakpoint will not currently be hit. No symbols have been loaded for this document

    Dotaz

  • There was a similar question posed on the C++ forum back in February to which I responded yesterday, but unfortunately, did not get a response. I am therefore putting this question in the VB forum.

    I have a VB 2005 project which is actually an add-in to Outlook 2003, which was I was able to debug fine until earlier this week. Now I cannot debug it at all - the message in the subject is displayed when I hover the mouse over the breakpoint which shows a yellow icon in place.

    Can anyone here tell me what I should do to correct this?

    13. dubna 2006 18:04

Odpovědi

  • Click on the Menu item for Build then select Configuration Manager. Here you can set the configuration for each project in your solution. In order for the ide to debug your library, it needs to be able to find the debug symbols which are generated when you build with the debug flag turned on. This is easiest set by setting the configuration option to debug.

    As far as building a class library, you can do it any of a number of ways. Selecting the library, right clicking and selecting Build, or using the build menu option.

    Jim Wooley
    http://devauthority.com/blogs/jwooley

    13. dubna 2006 20:28
    Moderátor

Všechny reakce

  • Make sure that you are compiling in Debug mode not Release mode. Also make sure that you have compiled your most recent version. If you have made changes to your source since the last compilation, you will not be able to debug it.

    I'm not sure if the same holds true for C++ as I've never used it, so YMMV.

    Jim Wooley
    http://devauthority.com/blogs/jwooley

    13. dubna 2006 19:12
    Moderátor
  • I too have a similar problem, but I do not see any way to specify a "Debug" build.  My project is a class library and I can only Build it.  If I hit F5 it forces the "Debug" build which in subsequent testing will cause the debugger to fire.


    13. dubna 2006 20:20
  • Click on the Menu item for Build then select Configuration Manager. Here you can set the configuration for each project in your solution. In order for the ide to debug your library, it needs to be able to find the debug symbols which are generated when you build with the debug flag turned on. This is easiest set by setting the configuration option to debug.

    As far as building a class library, you can do it any of a number of ways. Selecting the library, right clicking and selecting Build, or using the build menu option.

    Jim Wooley
    http://devauthority.com/blogs/jwooley

    13. dubna 2006 20:28
    Moderátor
  • I have checked as you suggested, but all items are as they should be and I still see the same error. This worked in March, but stopped suddenly just before I raised the original question.

    Hope somebody can provide some assistance here. Otherwise, I will have to go back to VB6.
    30. dubna 2006 20:42
  • hi,

    I have same problem ,, I built a shared add-in it worked fine but now it does not work, when i set start external program to Word.exe it does not work but when i set the external program to Excel.exe it works,

    in the former case (word.exe) i can not debugg it and at the breakpoints i get message like "the breakpiont will not currentyl be hit , no symbols have been loaded for this document,"

    but if i set start external program to excel it dont get this message.

    4. května 2006 13:45
  • I had the same problem. I fixed it for a moment by changing the project's "Generate Debug Info" option from "None" to "PDB Only. " To get there, right click the project name in the Solution Explorer and choose properties. Then choose the Compile tab on the left. Click on the Advanced Compiler Settings.

    However, the problem returned... 

    8. května 2006 2:42
  • I have had this problem on and off, particularly with a class file that is part of a web service, and read many suggestions to it. Certain things DO help, such as debug building the assembly before setting the breakpoint, and set breakpoints right at the first line of code that you would be stepping into. Also go to Tools >> Options and under the debugging tree node select General. There you need to uncheck "Enable Just My Code"...this usually helps but it also seems to mysteriously re-check itself.   I am fairly well convinced due to the inconsistancies here that this is a flat out BUG.
    • Navržen jako odpověď cheeta 28. ledna 2010 9:19
    13. června 2006 2:48
  • I've seen this once.  I closed the app, re-opened it, clean and re-built it in debug & release mode, which seemed to work.  Looks like a bug to me


    • Navržen jako odpověď Thiriveni 8. prosince 2010 7:53
    13. června 2006 10:23
  • I'm having this same problem.  It started when I re-installed XP Pro after having done the initial development work on Vista (Vista has too many security and UI problems).  I've tried a number of things to get around the problem, including your suggestion above, but it didn't make any difference either.  I also noticed that the source file that I'm attempting to set a breakpoint in gets the "readonly" blue flag set on VS's tab for the file as soon as I do a "start debug"/F5.  I don't know if that's related or not.  If I look at VS's "output" from the compilation and loading, it clearly is not loading the symbols for the project/class that's giving the problem; the "main" and another project/class both get their symbols loaded OK.  But I don't know why or how to fix it.

    I'm beginning to believe that it's a VS problem, or something that is, at least, very obscure.

    Tom

    11. srpna 2006 0:16
  • If you are using the vb profile, then when you hit F5 you will get a debug build, but if you hit build you will get a retail executable. The simplest way to get things working again is to go to delete the bin directory under the solution/project path and then hit F5 again.

    Hope this helps,

    11. srpna 2006 0:34
    Moderátor
  • I'm getting this very same problem and having absolutely no luck fixing it.  The problem started after I moved the app from my local machine to an actual web server and upgraded my computer from Windows 2000 SP4 to Windows XP SP2.

    I can't delete the contents of the Bin directory since this is an ASP.NET application and in VS 2005 I have not been able to find a "bin" directory where it compiles all the code (which I really hate by the way).

    15. srpna 2006 20:04
  • So are we saying this is a known problem that essentially has no solution?  Man, I'm up the creek if so.

    I need to develope a PPC2003 app via VS2005 using the VB.NET IDE.  I just created a simple single button application that when clicked shows a "Hello World" messagebox.  If I run it in the emulator, the breakpoint works perfectly.  However if I deploy and run from the device, the breakpoint disables as indicated in this thread. 

    Is there no help for this?  Is this the kind of thing I might call MS directly on and hope to get some help with?  If I can't get this solved, I'm in real trouble...

    16. srpna 2006 22:42
  • There are a couple of reasons why you could be getting the yellow icon:

    • PDB not present or doesn't match the executable
    • PDB doesn't match the source
    • DLL hasn't been loaded.

    What's the exact description that you are getting?

    17. srpna 2006 4:06
    Moderátor
  • Alright, this CANT be it.  Anyone else try (re)installing the .NET Framework v2.0 SDK?  I downloaded all 300 something mbs of it, installed it, ran the same app I mentioned above and BAM!  Breakpoint hit.  Problem solved.  Could it be you guys need to (re)install the SDK too?
    22. srpna 2006 22:28
  • I had a similar problem recently:
    My program, as specified in "Start external program", simply shutdown when I tried debugging my plugin (a VB.NET class lib, written in VS 2003)

    The solution to problem was to uninstall .NET 2.0 Framework (I only had the runtime installed, but apperntly, that was enough)

    After uninstalling 2.0, my 1.1 plugin could now be debugged fine again!
    (Bill Gates and c:o are now officially off my christmas card list )

    23. srpna 2006 8:33
  • I got the same problem today and finally I figured it out .Maybe it'll works for you guys .I think you should check the project properties .first i chose new->vc++->general->... and phehaps it means you gotta figure "something " on your own ,i don't kown what it is but i think here is the problem ,so ,when i tried to debug this"The breakpoint will not currently be hit. No symbols have been loaded for this document" happened .

    I suggest you choose the specified project when you new one ,and maybe you won't hit this problem .

    Hope this works for you .

    24. srpna 2006 12:07
  • hi guys,

    i have migrated my website from vs2003 to vs2005 and it stopped debugging the pages. i was getting a similar message. after desperately looking for an answer in the web for at least two months or so, i sorted it out myself. it is as simple as this. select each page on the project, check properties, set the value for debug to "true".i tried everything else but none worked. but this one worked. hope this works for some you guys also. the symptoms are like this, you migrate a web project and then the pages on the old project stops debugging, but if you create a new page  with debug property in the web.config file set to true, it works only for that page.

    25. srpna 2006 6:13
  • I am having the same problem.  I built a shared MS Word 2002 add-in which worked fine, and i was able to debug it successfully yesterday.  I restarted my machine over night and this morning I could no longer run in debug mode.  Now I am seeing the following behavior...

    If i do a fresh install of my add-in, i can get it to execute by opening up word seperately,  but as soon as i try to run it through the vs.net debugger, it not only won't hit breakpoints, but it won't function at all.  Then if i stop debugging and try to run it by opening word independently again it doesn't function at all that way either.

    If i do an uninstall/reinstall of my add-in i can get it to work outside the debugger again, but as soon as i try to debug i lose everything. 

    I have created empty test projects that do nothing but display a message box when word opens and they exhibit the same behavior.  I am fairly new to Office programming.  If anyone has any suggestions I would be very greatful.

    31. srpna 2006 18:07
  • Same problem here with VS2005 / CF2 .

    In my C# Mobile5 app (a hello world with a message box) the breakpoints are disabled when deployed and debugged on the device.
    But when i deploy the app on the emulator, the breakpoint keeps alive and the app stops nicely when it is hit.

    Works like a snail but at least i can work !!
    I tried to reinstall the CF2 SDK and  the Mobile 5 SDK and the problem is still there.

    Edit 10/10/2006 :

    FIX: As was said earlier, enabling the "debug toolbar" made my breakpoints alive for my mobile 5 device

    6. září 2006 16:23
  • I had this problem when trying to debug a webservice in VS 2005.  I found the answer here.

    http://visualbasic.about.com/od/usingvbnet/a/WSDebug.htm

     

    13. září 2006 16:41
  • Did you manage to solve this problem?  As I'm having this at the moment!  Your response will be fully appreciated.
    25. září 2006 15:18
  • This is what worked for me ... I enabled my Debug Toolbar, that's it! Afterwards the breakpoints in my DLL Class started working. Even after I disabled my Debug Toolbar, my breakpoints continued to work.

    For the record, Bill Gates has never been on my Christmas Card list. I've run into too many of these "productivity killers" in my lifetime.

     

    3. října 2006 21:36
  • I finally fixed it by :
    Removing all the references in my project and re-inserting them taking care of the version i use.
    Manually delete the bin/release and bin/debug sub-directories in every project in my solution.
    De-installing and reinstalling .net framework (any version) and VS-2005
    Taking a close look at the target platform in my projects.
    My breakpoints came back !!

    After a short analysis, it looked as the .PDB and the assembly of one of my controls were not referenced at the right place, resulting in a desync between my sources and my binaries.
    What helped most seems to be re-referencing all, and killing the bin subdirs.

    Hope it helps
    Regards
    4. října 2006 6:37
  • I Guys Im new at these Forums But Not New in Programming.
    I Had a Problem When I Was developing a Windows Mobile Application (using MCSF).
    Everything was Ok while Debugging On the Device EMULATOR, but when I passed all projects in my solution to device Project,  Cleaned my Solution,  Rebuild it Again.
    Even after checking that all .PDB files where on the same place  as the .DLL or .EXE respective files, the only place where my Breakpoints where HIT was on the Slow EMU... 8 (
    I did something based on a topic on this thread, I Only Had Installed .NET Framework 2, but  not .Net Framework 2 SDK (300MB),  After i installed  .Net Framework 2 SDK, and .NET Compact Framework 2 SP1 (Only they call it SP1 Patch). Rebooted My PC, without windows telling me to do So. And After that all breakpoints where Hit : ) Sharan!!!


    6. října 2006 19:20
  • I had this same issue. Worked for a long while then started giving me the 'No BreakPoints Loaded' message. I tried checking all the suggested menu settings and deleting the files in the BIN folders. Frustrating!

    Nothing helped until I thought to go clobber the files in the PROJECT CACHE. This is located (for me) in the following directory:

    C:\Documents and Settings\Brian P. Mucha\VSWebCache

    Once I deleted these files and rebuilt I was able to debug.

    Regards,  BPM
    9. října 2006 18:41
  • I had the same problem and I fix it changing the username attribute of the processModel in machine.config. The value that must be set is userName="SYSTEM" to run as localsystem (high privilege admin) account.

    Regards,

    Luis Mezzina

    14. listopadu 2006 16:41
  • Hi,

    Not sure if this will help but this could be one of the reason:

    Eventho I had setup the proper debug options at the project level, for some reason VS2005 will not propagate these debug options to all the individual source .cpp files.  So if you try to set a breakpoint on a specific line in one of your .cpp files it is possible that debug symbol inforation was not created despite debug options being set at the project level.  This is what happened to me.  So what i did was, in the Project Explorer, click on the .cpp source file where you want to break, right-click and select Properties.  Expand C/C++ tree, go to General  and you may find that the 'Debug Information Format' is still disabled (despite it being set at the project level).  This is what i had, so i changed it to 'Program Database for Edit & Continue (/ZI) to match what i had set it at, at the project level, clicked on Apply, and OK and rebuilt entire project.  I was now able to halt execution at the breakpoint and single step thru code in that source .cpp that i couldn't before.

    Hope this helps out everyone.

     

    2. prosince 2006 17:47
  • Hi guys,

    After moving to a brand new PC i reinstalled VS2005 + SP1 and my apps etc... and ran directly in the same breakpoints issue.

    I pointed the solution from another threat at MSDN :

    As simple as installing the SP1 for CF2 !!

    It fixed immediately the whole problem !!

    Should work for everyone

     

    3. ledna 2007 14:44
  • Are all the projects included in the solution builded up without problems?
    I had the same problem cause there was an error in one of the seperate projects during building up the solution. I fixed the problem and everything is fine now.
    16. ledna 2007 8:47
  • I fixed it by going into IIS and removing the virtual directory, then back into VS2005 and used the "Create virutal folder" button in the options for the web project, then back to IIS to sort out impersonation info etc. Breakpoints came back.
    17. ledna 2007 14:01
  • I had a similar problem with a class used to build a DLL assembly.  In my case, it seems to have been caused by registering the assembly in the GAC via an installer project I had created, built and run on a previous occasion.  I uninstalled/de-registered the assembly via Control Panel -> Add/Remove Programs, and then the VS IDE was able to locate the debugging info.

    I can only assume that VS was attempting to locate the assembly by first looking in the GAC, then looking at the reference specified in my test program (which referenced the DLL project).  Once the assembly was removed from the GAC, VS debugging worked correctly.
    24. ledna 2007 10:42
  • Brian,

      I hear you.  I too had everything working fine, until 2 days back, when suddenly I could not debug any more.  I work on multiple projects (I am not talking about having multiple projects under the same solution, but literally work on 3 different .NET project), and suddenly I stated getting the same 'The breakpoint will not currently be hit. No symbols have been loaded for this document.'  when I open any of the projects and try to debug. 

      I too tried all of the solutions giving in this blog, nothing worked.  I tried to think, what must have changed that all of a sudden, I get this error.  It stuck me that 3 days back, my system had installed windows automatic update (since I had windows automatic update set up to kick in 3AM every day).  So, I looked at the recently installed Microsoft updates on my system, and found a .NET update.  I went to microsoft site, downloaded that update again, and re installed it, while no other application was open on my system, then restarted my system, and vola!!  I was able to debug again.

    Thanks,
    Babu
    26. ledna 2007 21:36
  • Check if the debug="true" in your aspx page.

    Debug is disable 

    <%@ Page Language="C#" MasterPageFile="~/MainMasterPage.master" AutoEventWireup="true" CodeFile="Facility.aspx.cs" Inherits="_Facility" debug="false"%>

    Debug is enable

    <%@ Page Language="C#" MasterPageFile="~/MainMasterPage.master" AutoEventWireup="true" CodeFile="Facility.aspx.cs" Inherits="_Facility" debug="true"%>

     

    31. ledna 2007 8:46
  • I also faced the same problem of not getting into debugger. when I google for solution I got this thread. None of the solution worked for me. Later one of my team mate solved it.
    The problem was that, I had installed the application, which was an add-in to word through setup. So later when I was trying to debug my application, it was referring to the installed one, but not the one run from devenv. I uninstalled the application and run the program, now it is going into debugger. Hope this may be the problem with few of you.

    31. ledna 2007 12:11
  • Donsabras,

    Thanks for your post.  It also solved my problem - loading .NET CF2.0 SP1.  I started seeing this debugger errors after I loaded VS 2005 SP1.  Apparently, that SP needs for the .NET CF2 SP1 to also be loaded.  After I loaded it and rebooted my PC, I could then hit breakpoints again when debugging on my WinCE 5.0 hardware device.

     

    4. února 2007 21:18
  • I had the same problem in a VC++ project. WHat bcw suggested worked well to solve the problem. I did not try to reinstall anything, I was looking for a quick fix. Thanks.
    9. února 2007 17:17
  • I tried most of the above which did not solve the problem for me.

    I ressurected an older version of my source code, copied over all the altered .vb and .resx files then ran Beyond Compare to look for any other differences.  The .ncb and .suo files were radically different.  Replacing those with those of the older version did the trick.

    13. března 2007 17:09
  • I had same problem

    How I got around it is I went in the Properties for the project and went to the start options and changed from default webserver to Use custom server  with the URL  for the project and Voila!!!

    Everything is working...............

    29. března 2007 12:17
  • I was also facing the same problem.I got my solution by checking the postback property of my server controls dropdownlist.By default it is set to false so I changed it to true and it works!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

     

    maybe this wn't work for everyne bt atleast u cn try it.

     

    Cheers!!!!!!!!!!!!!!!!!!!!!!

    4. dubna 2007 6:46
  • J,

        Was this for VS 2005 or VS 2003.  I have been chasing this problem for a while, and all suggestions I saw seem to apply to VS2003.  I cannot determine If this program is set to Debug or Release in 2005.  As far as I can tell both are being created.

    Thanks,

    Phil

    12. dubna 2007 20:26
  • I had the same problem when developing a program for a pda. The dll name had 2 capitals (ex. MyDll.dll) but after deploying to the pda the dll name on the pda only consisted of small capitals (mydll.dll). Because the MyDll.pdb on my local machine still was in capitals, VS2005 debugger could not load the needed symbols.

     

    I changed the 'Assembly name' (right click on project, tab 'Application ') from 'MyDll.dll' to 'mydll.dll' and the problem was solved.

     

    19. dubna 2007 9:21
  • I had this problem for a couple of hours in a pocket pc application and found the solution by accident. I had changed the application icon and deleted the previous icon using the windows explorer. However the old icon was still appearing in the solution explorer. So I removed that resource from the project and now I can debug.
    20. května 2007 12:29
  • I also encountered this weird problem, and tried all the mentioned things in this thread, nothing seemed to work, but it was only a problem in 1 specific project, so i renamed the project, and created a new project, and gently added all the things from the old project, and when I was done, the debug worked perfect.

    29. května 2007 10:06
  • Uninstall CF.net 2.0 and reinstall with CF.net SP1. That's all.
    31. května 2007 18:46
  • I had this issue using Visual C++ 2005 to write a native DLL and debugging a Visual Basic 2005 managed app calling it. Reinstalling CF SP1 didn't work for me. I noticed that while debugging under the modules tab in VC it said the module didn't load at the default load address. I went into Project Property Pages, under Configuration Properties, Linker, Advanced, and set a new Base Address (in my case 0x20000000, a number I got from a tutorial on base addresses.) Now I can debug.
    1. června 2007 5:59
  • I was debugging web site using VS2005 when the same problem happend to me. I reset Internet Explorer settings (Tools -> Options -> Advanced tab -> Reset...) and problem dissappeared.
    8. června 2007 16:31
  • I had some problems with this yesterday.

    The problem was that the 'obj' folder in the root of the solution was missing (And some sub folders in it).

    It seems that the folders themselves are more important than the files inside them.

     

    Hope this will help someone Wink

     

    5. července 2007 7:07
  • Had same problems. No yellow line anymore when creating and debugging a visual studio project.

    Tried to find a solution with the information in this article.

     

    Using VS2005 on XP SP2 working as user Administrator.

    Solution in my case was:

    Go to explorer:

    c:\documents and settings\administrator\My documents

    Delete folder "Visual Studio 2005" with all its contents (watch out is you have your projects saved there, I save them on separate directory so deleting this folder did not cause information-loss).

     

    Start Visual Studio and the folder "Visual Studio 2005" with subdir's projects, templates and visualizers is automatically created again with new files in it.

    Then debug worked again in my situation.......

     

    Costed me a lot of time to read and find a solution.

    I'll forgive Microsoft because of their marvellous SQL2005 CLR-system they introduced........

     

    Frank

     

     

     

    14. července 2007 12:37
  •  

    Try removing the references. Then re-refer them and rebuild your solution. Looks like the libraries that your program was referring has changed and is therefore unable to adjust the breakpoints.
    6. září 2007 15:55
  • I got this to work in C# 2005:

     

    1. I went to the Tools menu and selected Options;

    2. I checked the "Show advanced build configurations" checkbox.  Now the build configurations show in the Project Properties dialog;

    3. I displayed the Project Properties dialog (Project menu/Properties).  I now see the Configuration dropdown box.  I selected "Active(Debug)" item;

    4. I checked the "Define DEBUG constant" checkbox;

    5. I rebuilt the project.  Now there is a symbols file ([project].pdb) in the current output directory;

    6. When I debug, the symbols file is loaded and my breakpoints are now hit.

     

    I hope this helps.

     

    Will.    

     

    9. října 2007 2:14
  • Start debugging. Now select Debug->Windows->Modules. In the modules window taht now appears, check what the Symbol Status reads. If it reads "Symbols not loaded", then right click on that row, Load Symbols and select the corresponding pdb file.
    If the Symbol Status reads "binary was not built with debug info", you have not built your project with debug information.

    To do this:
    1) Goto Project->Properties
    2) Make sure "Configuration" at the top is "Debug"
    3) On the left, select "C/C++", then "General"
    4) On the right, change "Debug information format" to "Program Database for edit and continue (/ZI)"
    5) On the left, Select "Optimization"
    6) On the right, Change "Optimization" to "Disabled (/Od)"
    7) On the left, select "Code Generation"
    8) On the right, change "Runtime library" to "Multi-Threaded Debug (/MTd)"
    9) On the left, expand "Linker" and select "Debugging"
    10) On the right, change "Generate Debug info" to "Yes (/DEBUG)"
    11) Rebuild your project.

    Spent a day working this out.. googling always helps !!! A big thanks to these forums.
    14. října 2007 21:27
  • The only solution I found to this issue (which has happened several times to me as well) is not to use the built in default Casinni web server.  In the Properties Pages >> Start Options >> Use Custom Server.  Put in your base URL for localhost (ex: http://localhost/yoursite), hit ok and wala!  Let me know if this helped anybody.  When you have the boss breathing down your neck, we don't have time for this Mr. Gates!

     

    David

     

    17. října 2007 14:54
  • My setup:

    VS 2003, IIS6

    4 web services, each with their own project in the same solution. The forth web service is my startup project. I can debug into project 3 and 4, but not 1 and 2. Looking at the Module window, the dlls for project 1 and 2 are not there at all, even when the code in these projects is clearly being executed.

     

    After trying everything in all 4 pages of this post and many others, nothing worked for me. Finally, I tried this and it worked:

     

    -- Right click on the project that cannot be debugged->Debug->Step Into Instance. When the code gets executed, the dll was loaded in the module window and the breakpoint hit!

     

    -- OR...when I set the startup project to project 1, all dlls were loaded, and breakpoints hit.

    26. října 2007 2:05
  • This worked for me.  Thanks

     

     Anonymous556091 wrote:

    I had same problem

    How I got around it is I went in the Properties for the project and went to the start options and changed from default webserver to Use custom server  with the URL  for the project and Voila!!!

    Everything is working...............

    4. prosince 2007 20:10
  •  

    VS 2005, ASP.NET

     

    What worked for me after trying a bunch of what is in here was to remove my asp.net project from the solution. Close VS. Delete the original solution folder. Reopen the asp.net project and save all which recreated the solution folder. Set break point, hit F5.

     

    If you look inside solution file, you see lots of debug lines. I should have saved the old solution file to compare now that it works.

     

    32U

    18. prosince 2007 21:56
  • Verbose: a guess of my problem is listed in the final paragraph.

     

    This seems to be a general issue.  I am a novice C++ user and have been attempting to create a DLL via Visual C++ 2008 Express Edition, which contains simple functions which may be exported to a VBA function within Excel (via a

    __declspec(dllexport) command to declare exported symbols within the .cpp file - this may contribute to the problem - no idea).

     

    The function in VBA drops when it calls a function within the DLL.  I've mimicked similar calls to 3rd party DLL's from VBA, and am fairly confident the problem is not on the VBA side.  So my interest is in stepping through/debugging the the DLL (or the .cpp source file really).  When I set a breakpoint, I get the message that the breakpoint will not be hit and that no symbols have been loaded for this document.

     

    After going through numerous on-line and help forums, I haven't been able to pinpoint a fix.  However, I believe a main problem is that whenever I try to debug (Debug | Start Debugging), my DLL does not appear in the Modules Window.  Additionally, almost all of the DLL's which do show up (there appear to be about 70 - most of the standard DLL's on the machine) are listed with the message: symbols not loaded.  Because my DLL doesn't show up, I cannot right click on it to load symbols for it.

     

    Steps taken / other info:

    1).  tried rebuilding the application many times

    2).  tried completely deleting and redoing it from scratch

    3).  the .pdb file is in the same location as the DLL with the same name and time

    4).  my project is running on the debug version of the DLL and associated files

    5).  ensured there was only one instance of the DLL, project, etc. on the machine

    6).  right clicked on a DLL that is within the Modules window, selected Symbol Settings, selected Debugging | Symbols and manually added the directory with the .pdb file - even though I confirmed that this is the default location used by the project

    7).  checked that Enable Just My Code is not selected within the Symbol Settings | Debugging | General menu

    8).  tried placing the DLL in the C:\Windows32\ directory just to see if the Modules Window would "see" it

    9).  tried adjusting a few other things to match suggestions regarding optimization settings, etc.

    10).  tried selecting Load DLL exports within within the Symbol Settings | Debugging | Native menu (although I am not familiar with what this may actually be doing); this caused most of the DLL's in the Modules window to have a listing of Exports Loaded, but did not appear to affect my issue in any way - again my DLL is not within the Modules window

     

    My naive guess is that my DLL is not getting loaded in some manner, since it never is displayed in the Modules Window.  I've tried to find a way to manually load the DLL or work to find it via the Modules Window, but there seems to be limited control.  Is there a way to force the DLL to load, or am I going down the wrong path?  I fear using a programming word I don't understand, but is there some fashion of registering a DLL or the like which I've failed to do?

     

    Thanks much.

     

    7. ledna 2008 13:22
  • Hi all - I don't know if you have had any luck - but I have been dealing with this problem for days.  We had a developer leave and copied all his projects to a central location.  When I brought them down to my laptop and tried to run them with the debug option and put a stop at certain point in the code same thing happened.  After reading a lot and much pulling of hair - tried the menu option Project and bottom of the list is the properties for the Project.  Click on the references tab and double check the reference paths (it is a button you can click on) lo and behold the wrong path to the bin folder was in there - so I browsed to the correct bin folder for this project and added the folder to the reference path, didn't even remove the other path - and it works - started it up and the stop actually worked - best day of my life - how is that for sad!!!  Hope this helps!

    • Navržen jako odpověď Dave Shinkle 12. června 2012 0:51
    14. ledna 2008 22:50
  • I had this same problem when trying to debug a windows service. After trying everything I could find online, I finally figured it out myself. 

     

    I pulled a class project into my solution in order to reference and debug it, but the .dll was already registered in my GAC so VS ignored the project reference. 

     

    Easy fix. Open c:\windows\assembly - If you see the dll, right click an uninstall. Clean, rebuild.

     

    16. ledna 2008 16:38
  •  

    Unfortunately I wasn't able to find a simple one step change for my issue.  Even though I thought I had tried it before, I completely erased everything related to my project and set it up again from scratch.  It worked fine.  So I'm not sure what specific issue I created that caused the problem initially, although obviously I did something wrong.

     

    My new problem (this probably isn't the correct forum) is another thing which this naive beginner hoped would be relatively straightforward - but apparently (probably) is not.

     

    I'm trying to pass a VBA string variable into a DLL.  As simply as possible.  For now, I really could deal with any variable type (or combination of types) that would represent the easiest way to do this, with minimal overheard.  I could send the string from VBA ByVal or ByRef, although I'm generally declaring the variable within VBA as a string I wouldn't have a problem defining it as a variant instead, etc.  I can receive it as any type that the DLL would take (char*, string, BSTR, etc. - although if possible I would lean towards using something easier than an array of char* if possible).  Passing a value, a pointer, a pointer to a pointer - whatever.  I realize these issues I'm brushing aside may well eventually be quite important, for now I'm just exploring moving data from one environment to the other.  I do not need to pass this variable back to VBA - I only need to receive it initially within the DLL.

     

    My goal, if possible, is to come as close as possible to declaring the variable in any way necessary within VBA, and then just declare the incoming variable within my project as whatever type may be able to match (akin to string my_input_from_VBA).  Is there any combination of items/methods available within C++ to pull this off?

     

    Thanks.

    17. ledna 2008 4:40
  • ONE solution with multiple project solution.

    If you have 3 or more project is necesary that the initial proyect reference AND USE declaring at least one type of all the projects that you need to debug. If the .Net compiler detect that you are not using a project directly from start proyect the compiler don't generates the debug information.

    In spanish the error is: "No se puede cargar ningún símbolo para este documento"

    THCTase
    19. února 2008 12:14
  • In order to solve this problem in VS 2008, if mentioned in this forum steps dont help, please do the following: go to Build | Batch Build... and click Select All and then Rebuild.

    21. února 2008 2:08
  • Hi,

     

    Try this one...

     

    Debug="true" in aspx page directiv

    <%@ Page Debug="true"....%>

     

    26. února 2008 21:22
  • Ok guys - I'm a TOTAL Hak with development - and I already know Im WAY over my head on programming... but I found my solution after I had built a deployment - had the same problem

     

    What I did - is:

     

    Right click on my project in solution explorer ==> Properties

    Go to Configuration Properties

    For my main application (not my setup project) I used the combo box to change from "Release" to "Debug"

    Then it worked.

     

    I'm simple - So I like a simple answer. Got lucky on this one... hope it helps someone else too

     

     

    28. února 2008 16:43

  • I have this problem when the date and time of some project files is in the future. Change the system time to a later date. This works.

    from the seven hills by the Rhine
    Achim Busenbender
    Wirtgen


    17. března 2008 10:46
  •  

    After doing everything I read here nothing worked for be.  However, what did work was to 1) delete all breakpoints 2) start debugging 2) then add new breakpoints.  Now it works (for how long.... I don't know......).

     

     

    I found many times (in ASP.Net) that the breakpoints would be hollow until the actual link or page or button was clicked or loaded.

    21. března 2008 20:35
  • This works for me. It can be a debug symbol version mismatch so that debug symbols don't load. At VS2005 VB start the debugger (F5). Click debug -> windows -> modules. In the window that opens right click on your module and then 'symbol load information'. Use 'symbol settings' to find your correct symbol (.pdb) file (which has matching date and time to your executable). This path you find manually will be remembered subsequently because the debugger searches a number of paths looking for valid symbols. If you can't find correct symbols initially, follow the other advice here regarding versions and building for debug, and then try this again.

     

    2. dubna 2008 16:43
  • Hi,

     

    I got the same issue, but fixed that *damn* thing,,,

     

    Add this into your web.config

    (

    <add assembly="EnvDTE, Version=8.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

    could be different for your environment

    )

    <system.web>

    <compilation debug="true">

    <assemblies>

    <add assembly="EnvDTE, Version=8.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

    </assemblies>

    </compilation>

    </system.web>

    10. dubna 2008 16:06
  • Fortunate for me that you posted this, and I spent "only" a couple hours searching for this solution. Thank you very much!

    14. dubna 2008 20:41
  • I followed this lead and it solved my 3 day old problem immediately.  I had been doing some clean-up and made my project naming consistent within my Windows Mobile Solution.  My class libraries would no longer debug.  Visual Studio 2005 mistakenly changes the case of the Project name from mixed to lower, when deploying them to the device.  Changing my library project names back to lower-case allowed me to debug again.  Thank you Han.

    5. května 2008 2:07
  • This is useful for finding out whether or not your project settings are set appropriately to generate and load debug symbols.  A lot of the posts on this thread relate to not having debugging set up correctly - but that is a separate issue from the real problem.

    The sticky problem here is where the modules window shows that symbols absolutely and unquestionably are loaded but you still get the message that symbols are not loaded on the tooltip for the breakpoint when the red circle just has a border (IE not filled) and a wraning icon.  The usual tricks like deleting all the files in all the debug folders and rebuilding the entire solution DO NOT fix the problem.

    I've never had this problem with VS2003 or VS2005 but now have it on VS2008.  I was happily debugging, stopped my app and started debugging again.  Now spending my time in a Microsoft generated time wasting sink looking for a solution :-(((


    9. května 2008 9:40
  • This is useful for finding out whether or not your project settings are set appropriately to generate and load debug symbols.  A lot of the posts on this thread relate to not having debugging set up correctly - but that is a separate issue from the real problem.

    The sticky problem here is where the modules window shows that symbols absolutely and unquestionably are loaded but you still get the message that symbols are not loaded on the tooltip for the breakpoint when the red circle just has a border (IE not filled) and a wraning icon.  The usual tricks like deleting all the files in all the debug folders and rebuilding the entire solution DO NOT fix the problem.

    I've never had this problem with VS2003 or VS2005 but now have it on VS2008.  I was happily debugging, stopped my app and started debugging again.  Now spending my time in a Microsoft generated time wasting sink looking for a solution :-(((
    9. května 2008 9:43
  • This is useful for finding out whether or not your project settings are set appropriately to generate and load debug symbols.  A lot of the posts on this thread relate to not having debugging set up correctly - but that is a separate issue from the real problem.

    The sticky problem here is where the modules window shows that symbols absolutely and unquestionably are loaded but you still get the message that symbols are not loaded on the tooltip for the breakpoint when the red circle just has a border (IE not filled) and a wraning icon.  The usual tricks like deleting all the files in all the debug folders and rebuilding the entire solution DO NOT fix the problem.

    I've never had this problem with VS2003 or VS2005 but now have it on VS2008.  I was happily debugging, stopped my app and started debugging again.  Now spending my time in a Microsoft generated time wasting sink looking for a solution :-((((
    9. května 2008 9:46
  • I'm not sure if this will help anyone, but I thought this would be a good place to post this:

    I was getting the "The breakpoint will not currently be hit.
    The source code is different from the original version." error, and it turns out that this was simply because I had two files in my project with the same name (they were in different places on my drive, of course).

    So all I did was rename one of the files and then did a Rebuild on the project, now I can set breakpoints again!

    Good luck!
    -Miq
    29. května 2008 19:44
  • I recently changed to a new computer and a fresh install of .net.  I am still using VS2003.  My debugging gave issues.  I then created a new web application and all was fine.  I could debug old applications as well. 

    Today I tried to debug an old application and got the above message.  I lucked out and found a solution that works for me on my first Googled site.  The answer was:  somehow my local ASPNET user account lost it's permissions on my computer.  It has to be part of the DEBUGGER USERS group.
    4. srpna 2008 17:09
  • This problem can manifest itself when the directory in which the project is lodged is set to read only.  Even with the web.config debug switch on and project is set to compile and trace in debug, the Visual Studio cannot write debug information (PDB) to the project directory and hence linking to this at run time will therefore fail.

    I suggest going in to the directory and making sure (recursively) that it is read-write.  Suspect the problem may arise from use with Source Safe/TFS setting directory permissions after checkout, might have resulted from a checkout which failed to complete and left the directory permissions in an unknown state.
    15. října 2008 10:51
  • the solution to the problem ( if you are using asp application and visual basic .net) is to go to project properties (right click on your project name and select properties) and click on configuration properties and select debugging. Make sure you have ASP debugging check box checked.
    16. října 2008 19:01

  • Under VS 2008, I solved the problem by doing the following:

    You need to add the directory that contains your solution to the Directories containing source code.

    To access the Debug Source Files property page, right-click on your Solution in Solution Explorer and select Properties from the shortcut menu. Expand the Common Properties tree, and click the Debug Source Files page, then click the Add New icon and specify the folder (directory) that contains your project.

    Directories containing source code: Contains a list of directories in which the debugger searches for source files when debugging the solution.

    Jamal

    * Mark post as helpful if this tip helps.

    18. listopadu 2008 22:23
  • I had this same problem. 

    Deleting all of the contents of the BIN > DEBUG folder seemed to fix the problem.
    • Navržen jako odpověď Emrah OZDIL 25. listopadu 2008 23:02
    24. listopadu 2008 14:44
  • The "MyApplication.exe" file in your Projects Debug folder causes this problem. Delete your "Bin\Debug\******.exe" file then try again. It must be the solution
    • Navržen jako odpověď Emrah OZDIL 25. listopadu 2008 23:01
    25. listopadu 2008 23:01
  • One solution to this issue... (VS2005)

    1. Select the Solution node in your Solution Explorer...
    2. Select Properties from the context menu...
    3. Select Multiple Startup Projects...
    4. For each project you want to debug, select Start from the action drop down.
    30. ledna 2009 20:09
  • Hi,

    If this is still an issue, you can goto project, properties, build, scroll down to advanced options. In here, you will need to set the debug info as 'pdb-only'.
    Now compile and press F5, vola you should be able to hit your break point.

    Enjoy!

    6. března 2009 0:35
  • I, too, was getting the 'hollow' breakpoints and the above message, regardless of how I set project
    properties, Debug or Release, code directories, etc.

    What happened that was interesting is... while the breakpoint red dots down the left had gone
    yellow/hollow/error-state, I ran the program in debug anyways, and when the breakpoints were
    hit, then they went red and started working again.

    HUGE problem, what a pain in the butt for VS to just start freaking out like this, with a message that
    is incorrect, and no immediate pointer to possible solution.

    once again, we lose, MS wins
    10. června 2009 18:53
  • I know this was posted some time back and you've probably long since handled the issue.

    The real issue here is this: What the ____ are symbols and where to they come from? :)  I work in Web Development and this comes  up frequently when the DLL for an assembly which needs to be debugged isn't in the website's bin folder.

    Symbols ... I don't know what the ____ they are but I do know a DLL file makes them. :)  Someone should put in the error message this additional info: "Your project assembly needs to be loaded in the correct \bin folder for the symbols to be generated.  Where is the assembly (DLL) file being assembled?  This is probably currently in your (drive letter):\ ... \project\bin\debug or (drive letter):\ ... \project\bin\release directory. For a website, this should be in the top level bin folder.  IIS, for example, looks for the DLL at this folder."

    I googled this error just to see if the social msdn site even detailed an answer like this.  Nope ...doesn't.  Well, programmers who create Microsoft products probably refer to "symbols" rather than where they're generated from and it doesn't occur to them that developers may not make that connection.  It took me longer than I'll ever admit to make this connection. :)

    I hope this helps.

    Postal Mike :)

    I live to code, I don't code to live ...
    12. června 2009 16:04
  • btw, the blank that got generated did not contain a 4-letter word, I should have put "heck" in for the word which designates the domicile of the Devil ... my bad.  Just want to let all viewers know I do have some couth.

    I do my swearing at my computer at home, in private, away from wifi cafes ... :)

    -- Postal Mike
    12. června 2009 16:08
  • I run into this sometimes too.  What's worked so far:

    From the Build Menu, Clean Solution, then Build Solution.

    If that doesn't work:
    - close VS
    - delete all Bin and Obj directories in the solution

    What a pain...

    -Tom Bushell
    23. června 2009 20:34
  • Hey MS/the people that dont fix this bug.
    I h-o-p-e y-o-u d-i-e !

    3 hours counting
    6. července 2009 13:05
  • Hi,
    I am also facing the similar problem as mentioned by you, the module will be never displayed in modules window. Have you found any solution? If yes, can you reply me with your findings.

    Thanks,
    Vijay
    30. července 2009 3:44
  • Hi,
    Thank you very much. Your solution is only one which is worked for me perfectly. I recommend others to use this solution.
    Thanks again, coz I was very tired in finding the solution before this.

    Cheers........
    4. srpna 2009 15:45
  • Hi,
    Can someone provide a pointer on this, I tried closing down studio but still the same problem.
    I get a yellow exclamation mark on the breakpoint and my website project is definately set to DEBUG.
    Thanks,

    Update: Actually, when I put the breakpoint elsewhere it was ok, even though the original breakpoint wasn't.
    But now the old breakpoint which wasn't working IS?!? If that makes sense.
    18. srpna 2009 15:19
  • Hi,

    I found the solution for this problem. Follow these steps to resolve this issue.

    1) Stop the current project
    2) Go to Build Configurarion manager- > Make sure that Active solution configuration should be in debug mode and
    3) Project Configuration column also should be in Debug.
    4) Change this and close it.

    Now start your project. your debugger should work.


    Thanks,
    Krishna Chaithanya HR

    2. září 2009 11:31
  • Also make sure that within IE go into Tools - Internet Options - Advanced tab and make sure the 'Disable Script Debugging' is unchecked.
    29. října 2009 20:13
  • Also when in the Configuration Manager make sure that all the projects are checked. I inherited a project from someone else and the libraries were checked but not the web site. Once checked debugging ran well.
    17. listopadu 2009 13:29
  • Your Problem : Debugger problem "The breakpoint will not currently be hit. No symbols have been loaded for this document." My Simple Working Solution : > Go to Project Property. > Go to Compile Tab. > Click on Advanced Compile Options. > Click on Enable Optimizations. > Select Full on Generate Debug Info. > Save The Project. > Debug it. Enjoy .NET Development.
    30. listopadu 2009 2:37
  • Just make sure that ur bin folder has pdb file along with the dll of the project you want to debug. if not then copy pdb file and paste in debug folder.
    30. listopadu 2009 6:00
  • I've used Visual Studio 2008 and its ancestors for the past 12 years.  I've had this problem regularly, and usually a clean/rebuild does the trick.  Sometimes that failed, and I'd just pull the whole solution out of source code and start fresh.  Yeah, make sure you built the debug dlls, got the pdb etc etc.  But in the end, there's a bug somewhere that I could never put my finger on.

    So this time, new company ... and their source code mgmt and build processes just aren't as robust so there is no real "start totally fresh' option.  Ended up making a copy of the folders/solution I started with originally, tested that and I could debug nicely.  Then moved all my source code changes into that folder, updated the project to include the stuff I added.... and that worked too.

    Why must everything MicroSoft produces suck?  I am thinking it's a company policy.  Seriously - I don't know how the employees sleep at night. 
    11. prosince 2009 18:08
  • I have been having this problem with the debugger all day today; and finally found a resolution "by chance":

    Having initially failed to get any of the break points working the normal way; I have resorted to the more desperate measures of adding the following line to the top of the method I was trying to debug:

    System.Diagnostics.Debugger.Break();

    Thereafter after; the problem was resolved for all other break points that did not work before adding the line above.

    The only explanation I could think about for why this worked was that the Break() method have forced all symbols to be loaded. Unbelievable but true.

    Hope this works for you guys.



    Tarek
    14. ledna 2010 12:43
  • this was my fix: don't run the website from the file system, run it from IIS! simple, but effective!
    29. ledna 2010 9:45
  • I tried exactly what you are suggesting, even insuring that the dates and times on the PDBs were identical - they were.  It DOESNT work.

    I also tried the 18,945,632 other suggestions here and across the web - NONE of them work.

    No matter what I do, I cannot debug my Solution and it is pretty clear to me now, after a day and a half of trying to fix this silliness, that this is a BIG BUG, that this NEVER should have been released, and that all of us across the web trying to post various suggestions of what worked for this guy, but not that one, make us seem like dead fish flapping around on the deck of some ugly trawler called "Microsoft" gasping for air...  and along with that we get the added Bonus that even Microsoft's "support staff" dont have a clue what this is, or how to fix it.

    Arno Penzius (the futurist) warned of a day when man would make software so complex even its authors cant figure out what its doing...

    ...welcome to THAT day.

    3. února 2010 15:51
  • I 2nd Beebo!  This is a BIG BIG problem!  Come on Microsoft, help us out here please!!  I'm tired of messing with this stuff.
    I have a ASP.NET website application which makes use of some DLLs in assemblies which are already compiled and placed in the \bin directory.  Ok, so when I try to debug the breakpoint is disabled and gives me the 'breakpoint will not be hit' error.  I understand if the DLL assemblies may have got out of sync, but my breakpoint is in the Page_Load() event of an ASPX page.  Why on earth can it not hit the breakpoint there?!?  My project has the 'debug' option set and web.config compilation is set to debug.

    In the output window I noticed:
    ....
    'w3wp.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\System.IdentityModel\3.0.0.0__b77a5c561934e089\System.IdentityModel.dll', No symbols loaded.
    'w3wp.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\System.Design\2.0.0.0__b03f5f7f11d50a3a\System.Design.dll', No symbols loaded.
    'w3wp.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\System.Windows.Forms\2.0.0.0__b77a5c561934e089\System.Windows.Forms.dll', No symbols loaded.
    'w3wp.exe' (Managed): Loaded 'A_1bc91dee_f0ce_4f29_8ab7_17d2da8de34b', No symbols loaded.
    'w3wp.exe' (Managed): Loaded 'M_1bc91dee_f0ce_4f29_8ab7_17d2da8de34b', No symbols loaded.


    Could it be the last 2 in bold that is the problem?  I removed all files that I could in Temporary ASP.NET folder.  Closed VS, re-opened, rebuilt website, ran, and low and behold disabled breakpoints!
    24. února 2010 15:49
  • So are we saying this is a known problem that essentially has no solution?  Man, I'm up the creek if so.

    I need to develope a PPC2003 app via VS2005 using the VB.NET IDE.  I just created a simple single button application that when clicked shows a "Hello World" messagebox.  If I run it in the emulator, the breakpoint works perfectly.  However if I deploy and run from the device, the breakpoint disables as indicated in this thread. 

    Is there no help for this?  Is this the kind of thing I might call MS directly on and hope to get some help with?  If I can't get this solved, I'm in real trouble...


    Me too!  I am sooo in trouble with this error.  I am pretty new to the language (vb), new on the job, and working up against unrealistic deadlines even for experienced programmers!  I can't fix it and I may get fired because I can't actually program or debug my program while I am wasting days debugging Microsoft's program.  I don't get stack traces either....

    Please, if you get a solution please post.  All I have found is the same old stuff everywhere and it may fix it until you shut vs down, but it won't stay fixed!  Some suggestions have actually broke more stuff.  Microsoft on a lot of forums are like oh just shut down and restart.  THen you don't hear back from them.  My favorite is when they post that it is hard to track down the cause of this bug.  I know that.  I have been tracking it for three days to no avail, but I didn't write the program so why do I have to do this again??? Oh that's right!  If I don't figure it out I could get fired!

    THanks

    Christina
    17. března 2010 20:46
  • Nope that,,

    This problem interesting with Output Code versioning.

    For example consider you got an output code Version V1 and later you gerated another version V2 
    program think the current version is V1 but that is must be V2 this is the some condition for all this issures

    Solution: You can do some of that

    1- Set the debuger setting for the current output
    2- Delete or change old outputs
    3- Union all output units in a same file

    This is not a bug or an Error interesting V.S. but the optimization could be set by a better algorithm


    good lucks..

    Hamit YILDIRIM
    18. března 2010 9:34
  • Guys, I've had this before.

    Usually deleting the <solutionfilename>.suo file in the solution folder.

    Try it. It works for me though I don't know why...

    25. března 2010 12:20
  • My Visual Studio 2008 started giving this error all of a sudden. I tried most things mentioned in this forum but it did not work for me. Finally I tried the instructions mentioned here: http://techemployee.blogspot.com/2010/03/visual-studio-2008-breakpoint-will-not.html and it worked! I am so relieved I finally got rid of this annoying problem.

    31. března 2010 4:47
  • In VS2008 my web application suddenly stopped being able to run in debug mode and I was getting the couldn't load debug symbols message.  I couldn't build the project in debug mode but I had all of the other 'debug' settings enabled.

    I tried most of the suggestions in this forum apart from reinstalling the .Net runtime.  This is what worked for me:

    • In the menu I selected Project \ASP.NET Configuration
    • On the admin tool web page I clicked Application Configuration
    • On the next page I clicked Configure debugging and tracing
    • Make sure that Enable Debugging is checked, for me it was already checked
    • Click Back
    Hey presto, my debugger worked again.
    • Navržen jako odpověď dougloj 2. dubna 2010 18:22
    2. dubna 2010 9:40
  • I found that excluding the problem .aspx page from the project, doing a build, including the page back into project, and doing a new build (or doing a debug) seems to work.
    2. dubna 2010 18:30
  • I have done several things to deal with this issue and I also lost my yellow screen of death.

    I have to make sure Debug="True" is in the first line of code.

    I had to make sure that my debugging options  were set as the other users have recommended in this forum above.

    For my yellow screen of death that I still couldn't get when I did crash in the code.  I now have to hit the continue button one more time and it shows up(sometimes). This was after I installed the Elmah plugin out of desparation though.

    The thing that finally worked for me was this.  My solution has 4 projects in it.  One has to connect to the pda and also launches the web app.  When I was debugging, the one project that  launched the pda and web app project was set as the startup project since it launched everything else.  I noticed that I couldn't hit the symbols in the web app only.  So when I need to debug the web app, I have set that to "Start with Debugging" as well as the other project if I have to do something where both apps are needed or I can just turn off the other app and return the settings when I am done.

    Basically, if you need to debug that project's code, then "Start with Debugging" turn it on.  For class libraries you don't have to start them of course their symbols get hit when the code gets there if the project that references them is set to debug.

    Hope this helps!

     

     


    Christina
    7. dubna 2010 23:58
  • The simplest solution and the one that worked for me was to make sure "JustMyCode" was disabled in the registry:

    1. Close any running instances of Visual Studio.

    2. Using the registry editor, browse to the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\Debugger

    Make sure the value for "JustMyCode" is set to 0.

    Close RegEdit and restart Visual Studio. Hopefully this fixes the problem. It did the trick for me.

    Cheers,

    :)

    Dean

    26. dubna 2010 23:19
  • You might have reference from your source control. Make sure youhave current version's dll and no references from source control. If you have any reference you can permently remove the reference and rebuild your project. It should work now. Thast how I did for me.

    18. května 2010 17:57
  • Currently I delete the file that has the pdb extension in debug folder and works fine, but do not know if there is any side effect to this.

    Anyone know if there is any problem to erase the file with extension pdb?

    26. května 2010 1:10
  • Also may be you should run visual studio with 'Run as administrator' if you use VS on Windows vista.
    22. června 2010 8:51
  • I already use this option to "run as administrator" but the problem continues.
    The only way so far to solve this problem is deleting the file. Pdb files in my project. It is a tiring process, but it works.
    24. června 2010 1:38
  • I have a solution that contains five projects, and I was having the same problem. After spending 15 minutes trying to figure it out, I realized that I had been trying to debug a non-startup project by pressing the debug button when the startup project was selected.

    To debug the non-startup project, all I have to do is right-click the project, hover over "Debug," and click "Start new instance." Problem solved (at least for me).

    28. června 2010 17:44
  • ValTrof!! Thank you very much!! It really works!! I'm happy!!!!!!!! =)))))))))))))))))))))))))))))
    11. srpna 2010 3:59
  • This solution worked for me fine, too. I only changed the version number in the assemblyInfo when the problems started. (Building a WinCE programm with CF 3.5)

    Deleting all files in the VisualStudio folder in my user directory brought the debugging back on the track.

    16. srpna 2010 14:43
  • The pdb files are used for debugging. They will be created again, if you compile in debug mode. If you don't have the pdb files, you won't be able to use the breakpoints in your source code.
    • Navržen jako odpověď bluebeag 31. srpna 2010 20:54
    25. srpna 2010 6:21
  • For Visual Studio 2010 Silverlight application: Right click Web project, Select Web tab, check "Silverlight" in the Debuggers section. Golden.
    • Navržen jako odpověď Thoron 10. září 2010 9:17
    31. srpna 2010 20:56
  • I have had this problem a number of times with Winforms applications. It arises if you copy a solution from one folder to another. IMT-DK and others are correct about the PDB files. To solve the problem delete the contents of the BIN folder and OBJ folder. Re-compile and the breakpoints you set will be hit.

    There are obviously a number of different problem scenarios on this forum so this is the solution to only one case of the "breakpoint will not currently be hit". It seems that VS solutions are supposed to use relative file paths but the PDB files do not. This problem still occurs with VS2010!

    1. září 2010 20:33
  • Thanks, that worked really great. I was really annoyed by that message!!
    10. září 2010 9:17
  • Thanks to everyone who’s responded to this post before me…

    I have VS 2008 and had copied a project and have been having the same problem on and off.

    So far two things appear to be working for me

    1)     1- Deleting the BIN folder

    2)     2- Use Debug instead of build

    I did not reload any software. I don’t know yet it this a temporary fix or permanent…

    Cin

    27. října 2010 20:28
  • hi i am working on an application in vb.net 2008 i am getting error as following:-

    "the breakpoint will not currently be hit. the source code is different from the original version".

    also my break point color goes off and only border remailns showing the above mentioned error

    Please Help me

    19. listopadu 2010 18:00
  • Hello !

     

    I had the same problem. I don't need to reinstall anything.

    That resolved (for me):

    1. in  'C:\Documents and Settings\my.User.Name\Application Data\My.Project.Name' delete everything

    2. Clean Solution.

    Success !

     

     

    7. prosince 2010 10:25
  • hi

     

    Remove temp file form 

     

    1) C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files 

    2) Remove Obj and Bin Folder from the Application

    3) Not Build and try to run the application

    Break Point will be excute.

    Regards

    Praveen

    8. prosince 2010 13:34
  • I tried almost all the suggestions with no luck. However, I found the following blog that helped me solve the problem: http://geekswithblogs.net/dbutscher/archive/2007/06/26/113472.aspx.

    TT

     

    9. prosince 2010 6:53
  • Am am working on an Outlook addin using a deployment project to distribute.

    After trying all of the above, some of which had worked previously, what worked for me this time.

    During Debug - [Debug][Windows][Modules] - If symbols not loaded on project dll, right click ond manually load from debug folder

    In my case it said they didn't match.

    Unistalled any installed versions of the project and reinstalled the deploment project using VS (Right Click on deployment project and select "install")

    Then my Debug worked. I think this solution would only work for an add becuase the link between Outlook and VS was mucked up.

    But it may help someone else out there.

     

    22. února 2011 23:28
  • After downloading the symbols packages and installing them I got this error. I tried pointing the symbols dir to the dir I installed them with no luck.
    21. dubna 2011 11:36
  • Hi, I just encountered this problem but I don't think it was happening until recently.  I have a C# .net system calling a VC++ DLL and wanted to debug the DLL.  I got "The breakpoint will not currently be hit. No symbols have been loaded for this document" when I tried to stop at a break I put into the DLL code.  Using Visual Studio 2008.

    Answer in my case (and may not apply to anyone else :-)  ):

    Select the C# solution in the Solution Explorer, right click, select Properties, then select Web tab.

    Bottom line is "Debuggers".  ASP.NET was checked but "Native Code" was unchecked. 

    I checked "Native Code". 

    Problem was resolved and I could now put breaks in the C++ DLL code and have the debugger stop there so I could see what was happening.

    Don't know why this was not a problem months ago.  Seemed to show up recently...

    Thanks,

    Howard

    5. května 2011 18:37
  • Probably you have your app currently installed in your system (ie: from an old test), and some libraries are in your GAC (Golabal Assembly Cache). Try to uninstall it from Control Panel... and check it again.

     

    17. května 2011 8:59
  •  

    To debugg my DLL in VS2008, I had to:

    1.  Select Project Menu
    2.  Select Properties menu item.
    3.  Expand configuration properties
    4.  Highlight Debugging
    5.  Set debugger type to "Native Only" - previously it was set to auto


    I still get the break point will not be hit error and open circle with a ! in it but the debugger does stop on my debug line.

     

    This should have been addressed a long time ago as a hot fix. 


    5. června 2011 0:22
  • Tried a lot of thing, but finally I dropped the reference and re-added the dll reference that in the debug folder.  it worked!

    8. června 2011 20:35
  • I restarted my asp.net web server, then i was able to debug and get ride of the error "The breakpoint will not currently be hit. No symbols have been loaded for this document".
    Davanam Karthik
    10. června 2011 14:58
  • Hi. found the solution: it is very very simple:

    I deleted everything from the folder: debug

    and then i run the debugger: it works correctly.

    ps: i'm working on a windows application using vb.net. not asp.net

    15. června 2011 5:44
  • Dear All,

    Some time after we update the IE we might receive this error  , for that do this work around

    1. Open RegEdit
    2. Browse to HKEY_LOCALMACHINE -> SOFTWARE -> Microsoft -> Internet Explorer -> Main
    3. Add a dword under this key called TabProcGrowth
    4. Set TabProcGrowth to 0

    Prabakar
    10. července 2011 12:29
  • I had the same problem.

    in my trouble, Autocad loaded two differents files dll applications.

    They (main dll applications) had different dependencies, so what I thought was not the one wanted to debug.
     two dependencies differents, the first loaded was wrong.. that's all


    16. září 2011 4:25
  • My problem was that somehow the page load and init were missing the handles me.load and me.init at the end. Once I added that back everything worked for me
    29. listopadu 2011 20:08
  • Right Click on Your project> click Rebuild...   Hopes this will helps u....

    11. března 2012 9:59
  • Thank Nikhil...

    However this post is just a bit more than 2 years old, and needless to say, we figured it all out a long long time ago by doing the only thing one can do when they need help with any Microsoft product...

    Go to ANY site except Microsofts...

    Like their motto says; "Microsoft, where DONT you want to go today?"

    12. března 2012 18:29
  • I'm having a similar problem, except I've already selected every project to build in debug. Furthermore, I have to manually specify which executable to run because if I specify 'Start Project' Visual Studio incorrectly tells me that the wrong version of Outlook is installed. I've even performed a clean install of Visual Studio and Office.

    Sadly this is just one from a list of several thousand visual studio bugs which render the software unusable and not fit for purpose. Under no condition will I take a job in future which I have to use such an epic software failure. I am very, very, unhappy with Visual Studio, Team Foundation Server, Office, actually pretty much everything Microsoft release, every other software company seems to manage things okay, why can't they?

    17. dubna 2012 11:25
  • I just had the same problem with a project I tried to debug, and following the guidance in this thread didn't help.

    Eventually, I just created a new project, copied the code, compiled, and TADA! works like a charm... I just thought you should know that before looking for more complex solutions.. might save you some sweat:)

    Roy

    5. května 2012 11:17
  • This worked for me! Thank you!!
    10. května 2012 16:19
  • My project is under source control so I removed the dll that could not be loaded and then I selected "Undo pending changes" to get the dll back to my project. This solved the headache for me!

    I followed some steps from this guide:

    http://geekswithblogs.net/dbutscher/archive/2007/06/26/113472.aspx

    13. července 2012 11:26
  • I tried a lot of the options without success.  I found the dll was installed on the PC with the regasm command. I uninstalled it with "regasm <full path>/mydll.dll /unregister".  The IDE then started working and looking at the Class Library project in the Solution.
    19. července 2012 21:33
  • I have had this problem on and off, particularly with a class file that is part of a web service, and read many suggestions to it. Certain things DO help, such as debug building the assembly before setting the breakpoint, and set breakpoints right at the first line of code that you would be stepping into. Also go to Tools >> Options and under the debugging tree node select General. There you need to uncheck "Enable Just My Code"...this usually helps but it also seems to mysteriously re-check itself.   I am fairly well convinced due to the inconsistancies here that this is a flat out BUG.
    I know this is an OLD thread, but I had the same problem trying to debug a SharePoint 2010 workflow with VS2010 and this got me working again!  It didn't immediately make the error disappear, but it did indeed hit the breakpoint and then the error cleared.
    31. července 2012 18:20
  • I had this issue recently as well

    what I did was select Tools->Options->Debugging->General and unchecked   Require source files to exactly match the Original Version

    2. srpna 2012 20:14