none
Publish ASP.NET website + database to Windows Azure Websites

    Question

  • I've signed up for a test account on Windows Azure to test it out. I build a Hello world ASP.NET web application + database just for testing.

    I installed Visual Studio 2012 RC and installed the Windows Azure software.

    In Windows Azure I've created a new Website + Database, I think that is running fine (http://azuretest.azurewebsites.net)

    I downloaded the Publish profile from Windows Azure and import it in Visual Studio. When I publish the website I select to publish the database, select the right connection string (from the publish profile).

    After publishing I get this error:

    Error 1 Web deployment task failed. (Could not complete an operation with the specified provider ("dbSqlPackage") when connecting using the Web Management Service. This can occur if the server administrator has not authorized the user for this operation. dbSqlPackage http://go.microsoft.com/fwlink/?LinkId=178034 Learn more at: http://go.microsoft.com/fwlink/?LinkId=221672#ERROR_USER_NOT_AUTHORIZED_FOR_DEPLOYMENTPROVIDER.) 0 0 azuretest

    The url's in this error message links to articles from 2008 and 2010. I don't think that I can find any good info there..

    The error say "This can occur if the server administrator has not authorized the user for this operation" but I don't think I can authorize anything on a shared Windows Azure Website, can I?

    Thanks.

    Thursday, June 14, 2012 10:15 AM

Answers

All replies

  • Hi Marcel,

    Can you please post the screen shot of your publish settings from VS? Please make sure to mark out sensitive information if any.

    Also, for isolation purposes, can you please try and perfrom the similar operation using WebMatrix?

    Thanks,

    AJ


    Apurva Joshi, This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, June 14, 2012 4:57 PM
    Owner
  • Hi Marcel, I work on the Visual Studio Web team. When we released VS 2012 RC we had the hopes that we would be able to finalize the server side components of the Update Database checkbox by the time that the RC went out. Unfortunately we were not able to do that, so the Update Database checkbox in VS 2012 RC only works if you are publshing to localhost.

    We are working to get the server side pieces ready but we cannot commit to a schedule yet. I've blogged about this at http://blogs.msdn.com/b/webdevtools/archive/2012/06/14/vs-publish-dialog-update-database-dialog-disabled.aspx.

    Thanks,
    Sayed Ibrahim Hashim (MSFT)

    Thursday, June 14, 2012 5:12 PM
  • Thanks for your answer.. That clears up a lot.

    Friday, June 15, 2012 7:15 AM
  • Hi,

    I just tryed this again.

    Installed Visual Studio 2012 Pro (not the release candidate, but the final version). Installed the Azure software, made a simple website and a database (SQL Express 2012) with 1 table and 2 records.

    Downloaded the publish profile and published my project to Azure. The website goes without problems, the database and the table is going good. But the records in the table are not present in the Azure database. Why is that?

    Thursday, December 06, 2012 11:09 AM
  • All that said and done, I got the same error ERROR_USER_NOT_AUTHORIZED_FOR_DEPLOYMENTPROVIDER in VS2013 while deploying to Windows Azure Websites (WAWS) and nothing nowhere to find to fix it.

    It just so appears that my project deploys just great again after comparing the project file with a brand new one and finding the following difference, which I commented out to get it working again:

      <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Release|AnyCPU' ">
        <DebugType>pdbonly</DebugType>
        <Optimize>true</Optimize>
        <OutputPath>bin\</OutputPath>
        <DefineConstants>TRACE</DefineConstants>
        <ErrorReport>prompt</ErrorReport>
        <WarningLevel>4</WarningLevel>
        <!--<IncludeIisSettings>true</IncludeIisSettings>-->
      </PropertyGroup>

    So, right click the project and click Unload Project, right click it again and click Edit project.csproj and find the PropertyGroup with the condition matching whatever you're trying to deploy (Release|AnyCPU in this case) and make sure that line is commented out.
    • Edited by ewjnl Sunday, April 20, 2014 2:58 AM
    Sunday, April 20, 2014 2:55 AM