locked
Cannot install VS 2008 Beta 2 on Vista

    السؤال

  • I am getting an error stating that the .NET 3.5 framework cannot be installed.  It keeps failing with an error like this:

     

    [07/30/07,14:10:35] Microsoft .NET Framework 2.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (CBS). MSI returned error code 34

    [07/30/07,15:01:46] Microsoft .NET Framework 2.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (CBS). MSI returned error code 34

    [07/30/07,15:02:45] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0SP1 (CBS) is not installed.

    [07/30/07,15:39:14] Microsoft .NET Framework 2.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (CBS). MSI returned error code 34

    [07/30/07,15:40:30] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0SP1 (CBS) is not installed.

     

    Many people have posted a similar problem on Scott Gu's blog.  Anyone else run into this???

    17/رجب/1428 03:36 ص

جميع الردود

  • This looks like an error installing the CBS package.  Try the following...

     

    First, try rebooting the machine ... the CBS store could be locked and rebooting will unlock it.

     

    Second, try opening the Control Panel, select Programs & Features, click on the "View installed updates" located on the Tasks pane. Select and uninstall the following Windows updates:

    - Hotfix for Microsoft Windows (KB110806)

    - Hotfix for Microsoft Windows (KB930264)

    - Hotfix for Microsoft Windows (KB929300)

     

    If none of thes work, look in the CBS log file in your %temp% directory and copy the error section into this thread.

     

    - Karen
    17/رجب/1428 06:36 م
  • Thats the problem that KB110806 won't install.  MS actually had me try that manually and it won't work.  I look in the Event Viewer and it shows KB110806 failing multiple times...and its required by .NET 3.5..so that fails and fails the whole .net 3.5 framework installation.

     

    I tried installing it over 10x already.  I have none of the KB items u mention (I wish I did, because then it would of worked).

     

    Is there any way to unlock the CBS store by brute force?  I was able to install Beta 2 before 1x and I was getting an error with the toolbox not appearing..so I decided to uninstall and try from scratch.  That turned out to be a huge mistake since I can't install even .net 3.5 framework.  So something is definitely locking this out.  I am almost tempted to re-set Vista to its default state.

     

    17/رجب/1428 07:16 م
  • Would you copy the error section of the CBS log file in your %temp% directory into this thread?  That should help us diagnose the problem.

     

    17/رجب/1428 07:38 م
  • Karen, what is ment by the "CBS" log file? What is the exact name of this file?

    17/رجب/1428 08:54 م
  • Sorry.  Correction:  Look for %systemdrive%\windows\logs\cbs and it should be in there.

     

    Thanks,

    Karen

     

    17/رجب/1428 10:06 م
  • I sent the logs to a team in Microsoft.  Hopefully, they can resolve the issue.

     

    They also had me install the KB110.... MSU manually and that failed as well.  So, there is something in the config/registry blocking that installation (because I actually had it work 1x before).

     

    18/رجب/1428 01:51 م
  • Hi!

     

    Just wanted to say that I've had loads of problems trying to install Beta 2 (used to have Beta 1 installed). However, the large post in the thread (see link below) solved the problem (I think it's Office 2007 that's making trouble):

     

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=1928867&SiteID=1

    18/رجب/1428 03:34 م
  • I had mucho errors trying to do the same. The stuff worked after I removed anything to do with any related install 3.0 and above like asp.net 3.5. Since the install package gives you all you will need I would advise you uninstall everything that you installed above web developer 2005 express and everything to do with any previous orca release. its a bother but the 2008 beta works so well its worth it.

     

    19/رجب/1428 08:10 ص
  • I reformat my computer, reinstall vista, update to date. then install beta2, I got same error?

     

    clear machine! why?

    20/رجب/1428 03:20 ص
  • Can you share the dd_*.* log files?  I can take a look.

     

    -Karen

    25/رجب/1428 10:55 م
  • vista ultimate; office 2007 ultimate; vs2005 team trial; sql server 2005 trial...; powershell 1;McAfee Security Center;

     

     

    Both image burn to DVD and virtual DVD produces the following results:

     

     

     

    dd_install_vs_vstscore_90:

     

    [08/11/07,09:21:26] vs70uimgr: Entering DisplayMessage() method.
    [08/11/07,09:21:26] vs70uimgr: DisplayMessage_STARTTongue Tiedetup has encountered a problem while trying to copy:
    K:\Setup\VSSetupWatson\DW20.EXE
    Press Retry to attempt the copy again. Press Cancel to cancel setup.
    [08/11/07,09:21:29] vs70uimgr: DisplayMessage_ENDTongue Tiedetup has encountered a problem while trying to copy:
    K:\Setup\VSSetupWatson\DW20.EXE
    Press Retry to attempt the copy again. Press Cancel to cancel setup.
    [08/11/07,09:21:29] Setup.exe: AddGlobalCustomProperty
    [08/11/07,09:21:29] setup.exe: ***ERRORLOG EVENT*** : CSetupManager::CopyDirectory : problem copying: K:\Setup\VSSetupWatson\DW20.EXE
    [08/11/07,09:21:29] Setup.exe: AddGlobalCustomProperty
    [08/11/07,09:21:29] setup.exe: ***ERRORLOG EVENT*** : CSetupManager::CopyDirectory() - Failed to Copy Sub Directory: K:\setup\VSSetupWatson to: C:\Users\awm\AppData\Local\Temp\SIT24404.tmp\VSSetupWatson
    [08/11/07,09:21:29] Setup.exe: AddGlobalCustomProperty
    [08/11/07,09:21:29] setup.exe: ***ERRORLOG EVENT*** : InstallSetupFiles() Failure in CopyDirectory
    [08/11/07,09:21:29] Setup.exe: AddGlobalCustomProperty
    [08/11/07,09:21:29] setup.exe: ***ERRORLOG EVENT*** : CSetupManager::CopyTempFiles() - Failed to install setup files
    [08/11/07,09:21:29] Setup.exe: UnloadSuiteComponents()
    [08/11/07,09:21:29] Setup.exe: GetGlobalCustomProperty - Property: {383F0141-C682-4665-A69B-756E719C968D} - PropertyName: Process Return Code - Value:
    [08/11/07,09:21:29] Setup.exe: SETUP EXIT CODE - 0

     

     

     

    dd_error_vs_vstscore_90:

     

    [08/11/07,09:21:26] setup.exe: [2] Incorrect function.

    [08/11/07,09:21:29] setup.exe: [2] CSetupManager::CopyDirectory : problem copying: K:\Setup\VSSetupWatson\DW20.EXE
    [08/11/07,09:21:29] setup.exe: [2] CSetupManager::CopyDirectory() - Failed to Copy Sub Directory: K:\setup\VSSetupWatson to: C:\Users\awm\AppData\Local\Temp\SIT24404.tmp\VSSetupWatson
    [08/11/07,09:21:29] setup.exe: [0] InstallSetupFiles() Failure in CopyDirectory
    [08/11/07,09:21:29] setup.exe: [2] CSetupManager::CopyTempFiles() - Failed to install setup files

     

     

    Pls advse...thanks awm

    28/رجب/1428 01:46 م
  • I have been working at this for over a week now without resolve....pls help.

    Thanks!
    30/رجب/1428 12:24 م
  • I'm having the exact problem too.  Did you ever get it resolved. 

     

    Can anyone else help?

     

    Thanks!

     

    13/شعبان/1428 12:36 م
  • If you have Encrypting File Service disabled you will get this kind of error. Check in the Local Security Policy under Pblic Key Polices -> Encrypting File System. Right click Encrypting File System and check that the setting 'File encryption using EFS' is set to allow.

    If you joined to a domain with a domain policy that disableds EFS, you will have to dis-join the domain, check EFS, install and then re-join the domain.

     

     

    14/شعبان/1428 08:47 م
  • I did just that and still no resolve using the following steps:

     

    1) Changed policy by right clicking and setting to allow...nothing else.

    2) Retried previously burned image

     

     

    am i missing something else?

     

    Thanks,

    Anthony

    15/شعبان/1428 01:23 ص
  • nope...nothing as of yet.

    sorry,

    Anthony

     

    15/شعبان/1428 01:24 ص
  • Anthony -  Just wanted to let you know that I was able to install using a co-workers download.  I was never able to install using my download (which I did 3 separate times.)  I read somewhere that this problem was due to a corrupted file in the install.  This appears to be true.

     

    23/شعبان/1428 12:57 م
  • Hi Sandy -

    I'm very frustated at this time with all of this.  Any indication of where/how to get an uncorrupted file?...Was the corruption on my side or was it on the download site?

     

    Thanks,

    Anthony

    23/شعبان/1428 03:31 م
  • Hi,

    i am having same problem setup says cannot copy dw20.exe

    how do i install orcas?

    Thanks
    Satish
    24/رمضان/1428 02:33 ص